Jump to content


Most Liked Content


#7677 Cron Job and Marketing Campaign - SOLVED

Posted by Gundam on 31 July 2013 - 03:16 PM

I have some problem with the Marketing Campaign regards the Scheduled Jobs.

 

I set up the cron jobs in my crontab as in the tutorial http://zurmo.org/wik...-up-job-manager

 

the user that run the cron jobs is in the same group of the apache (www-data) and the group have +w permission on all files.

 

in the attachment (error.png) you can see the error that i regain when i enter in the Campaign description, but the cron jobs is set up correctly.... so i run it manually and found that one job return an error message:

.{zurmo@crono}.[commands]$ ./zurmoc jobManager super AutoresponderMessageInQueue
    Error: The specified job type to run does not exist.

i set up correctly all the mail settings (i guess), in the job.png image you can see the scheduled jobs working.

 

Is there another check that i miss?

 

 PLEASE HELP ME !  :wacko: 

 

Attached Thumbnails

  • error.png
  • job.png



#16121 Zurmo suddenly stopped working with a PHP Fatal error

Posted by rich on 11 March 2015 - 11:50 AM

My Zurmo installation was working fine until ... suddenly it wasn't.

 

Now, just trying to access the application gives a blank page. The error in the log is:

 

PHP Fatal error:  Call to a member function find() on a non-object in /var/www/redbean/rb.php on line 7320

 

Anyone know what is going wrong here?




#2664 My installation experience, room for improvement

Posted by radu on 17 November 2012 - 11:33 PM

Ok, until I figure out what's wrong, it's worth mentioning that on the default installation (with sample data) , when I click go to the Dashboard and I get to /app/index.php/home/default I get a big no-no:


An error has occurred. Please click here to continue to the home page. If the error persists please contact your administrator.

Undefined offset: 0




#2663 My installation experience, room for improvement

Posted by radu on 17 November 2012 - 11:28 PM

The package looks great, and I am planning to march along the community and help out with what I can. So I hope my installation experience can lead to further improvement of the software.

Initial setup was simple: I downloaded the stable tar.gz (revision id : 03f2734b34d3) and extracted and configured under LAMP to have it running as http://zurmo.somedomain.com not as /zurmo/
I made sure to chown the directory and the content to the ftp user and apache group and chmod to 7 for ftp and 5 for http, for minimal security.

However, when I went to the root directory in the browser, i get:

Application runtime path ".../zurmo/app/protected/runtime" is not valid. Please make sure it is a directory writable by the Web server process.

and then:

zurmo/app/assets is not writable.
zurmo/app/protected/data is not writable.

I went chmod 775 on all those dirs and I managed to get to the first page of the installation process.

However, again, after going to next step (app/index.php/install/default/checkSystem) I got this:

copy(zurmo/app/protected/config/debug.php): failed to open stream: Permission denied

For security reasons, at this point I did chown apache:apache to have this step allowed, and then back to chown vftp:apache after the installation was done...


Yes, it was fairly easy for me, but might not be so trivial to others. At least for the .tar.gz package you could do the 775 (or 770, or 777 but preferably not) in the archive. Or instruct the users to temporarily chown the zurmo folder to the apache user during installation, although this won't solve the first 3 errors. Or something else, each user mileage may vary...

After that, everything went fine, at least for the installation process...
I had some big failures on the unstable installation, but now I am moving to stable to make sure they are not only due to the "unstable" flag...
I will be back with a separate post, if nobody is upset by this one, with my experience on the default installation, as a user...

If additional info is needed, let me know, I will comply.


#28387 Zurmo release 3.2.0 is compatible PHP 7 !

Posted by Boban Perić on 05 December 2016 - 07:58 PM

Starting with the release 3.2.0, Zurmo is now fully compatible with PHP 7. As you all know PHP 7 brings significant performance improvements.

 

The old MySQL PHP extension was removed and replaced by MySQLi extension. Zurmo stays fully compatible with PHP 5.




#19978 Seeking Zurmo administrator

Posted by fournines on 10 May 2016 - 07:17 AM

We have recently installed Zurmo on our server, and need assistance configuring incentives, badges, and contests. Looking for someone who can assist us with this (and any other management tasks related to Zurmo) on an hourly basis.

 

Please PM me to discuss.




#28120 I am really new to Zurmo

Posted by raggimatteo on 29 November 2016 - 08:27 PM

I come from years using vtiger CRM and I have to admit that I loved vtiger but it is too much buggy.

Plus Zurmo looks to be better detailed and with more features, gamification included.

Soon I start moving from Vtiger crm to Zurmo, it will be a wonderfull experience.




#18439 Missions

Posted by poing on 16 September 2015 - 08:26 AM

How about allowing the creator of a mission, to set the reward?

 

 




#12580 pro/commercial version

Posted by thanh on 20 January 2014 - 03:42 AM

Ray

does pro version include management of upgrade, backup/archive ?

 

what is the price for 5 users ?




#19948 Increase attachment size limit

Posted by rathinaa on 05 May 2016 - 04:52 PM

I have the zurmo stable release 3.0.5 free version running on Centos 6.  I am trying to get to upload attachments greater than 1MB size, and I made the updates to the configuraiton files as suggested here: But the UI still shows a max limit of 1MB and when I try to add an attachment greater than that, it just keeps trying to upload, but unsuccessful.  I do not see any errors in the application.log though.  I ran into a article about max limit on memcached and increased that as well, still no luck.

 

Any thoughts?




#108320 Workflow - Sending duplicate emails

Posted by jasongeps on 13 June 2017 - 02:21 PM

I was wondering if anyone has had any issues with sending Email notifications from Workflow that generate a duplicate?

 

I have a workflow set up to send an email notication of appointments created through the system, I have the cron set up and working to make this work.

 

The email is sent correctly with the email template working - but instead of sending just one email - it sends two of them identical.

 

I've checked with my hosting company and they have informed me the emailing issue is coming from the software as the cron is set up correctly.

 

 

Can anyone advise?

 

 

Thank you




#117688 Report Summation error with more than 30 groupings

Posted by sandro on 25 July 2017 - 05:53 PM

Hi all,

 

When you create a report (summation) with more than 30 groupings, an error occurs and does not display the chart.

 

The error occurs in the "AmChartMaker.php" file at line 388. The cause of the error is because there are only 30 colors in the array.

 

My temporary solution was to reset the counter when it reaches 30, but I think there is a better solution.

 

Thanks.




#108710 Calendar notifications workflow

Posted by petejenkins on 21 June 2017 - 09:53 AM

Hi Saran, so long as the users are internal then the email functionality you are after is built in to Zurmo already. Get the Email SMTP Configuration settings configured in Admin and by default users will start receiving notifications by email. Notification settings can be adjusted per user in their My Profile section. Cheers, Pete




#44852 MODIFICAR LA VISTA DE MIS LEADS

Posted by DaniGO83 on 04 March 2017 - 09:07 PM

Hola, 

 

En el panel superior derecho puedes ingresar en ../app/index.php/designer/default/modulesMenu?moduleClassName=LeadsModule y allí podrás ver todos los campos que vienen por defecto, puedes agregar o modificarlos según tu conveniencia y asignarlos a las vistas donde desees que aparezcan

 

Saludos!!




#13067 MODIFICAR LA VISTA DE MIS LEADS

Posted by knt_277@hotmail.es on 21 February 2014 - 04:49 PM

Hola, soy nuevo en esto, y quisiera saber como modifico la vista de mi FORMULARIO "LEADS", el propósito de esto, es agregar un link a mi campo EMAIL para validar si ese email esta activo.

 

SALUDOS, Y GRACIAS...




#19410 PHP 7 support

Posted by Administrtr on 18 February 2016 - 07:35 PM

It seems current version 3.1.0 doesn't support PHP 7 . PHP 7 support will be a super bonus. ( Also I can't use it till that as I use PHP 7).

 

Thank you

I'm using 3.0.5 atm... what exactly doesn't work with 3.1.0? I've had no issues at 3.0.5




#105263 Pagination causes duplicate listings

Posted by turbo2ltr on 06 April 2017 - 03:33 PM

We have a list of 104 leads. Put leads in owner order. Click the show more so all leads are shown.

 

The newly shown items will be duplicate entries in the list (pointing to the same record ID as other list entries).

 

Seems that when in Owner order, the "show more" button does not start at the correct offset.

 

For instance we have 104 leads. I have my profile configured to show 100 at a time.  So I get stickyOffset 0 to 99.

 

I click the more button to show the last four, and it does show 4 but it shows me the same records (same ID) as stickyOffset 88 to 91. Black line is where the Show more bar was.

 

zurmodups.png

 

 

This does not seem to be a problem when ordered by other fields such as name or source.




#105310 Merge tags not working

Posted by turbo2ltr on 07 April 2017 - 03:28 PM

When creating a new task from a workflow, I tried a few different ways (after having to search through many forum posts on how to do it) and none of them actually work.

 

zurmotagmerge.png

 

What am I doing wrong?  It never converts the tags.

 

Two most frustrating things about Zurmo is the complete lack of documentation, and the little that is documented doesn't actually work.

 

At this point I should have just paid for a different package because I've spent more hours trying to chase down bugs than what the other package would have cost.. Yes, I know, free software, yay!  I need to remember time is money.  I could have spent $1000 on a CRM and still been ahead at this point based on the time I've spent trying to fix Zurmo bugs or make up for the lack of docs.

 

 

 




#28122 Zurmo Connector for WordPress

Posted by raggimatteo on 29 November 2016 - 08:43 PM

Great! why don't publish it also in https://wordpress.org/plugins/ ?




#119155 Getting all the data via API

Posted by sica07 on 31 July 2017 - 11:17 AM

Hello,

 

Is there a way to retrieve all the  Contacts from the database?

Right now I'm doing  a search with no parameters, but the API is returning only the first 10 results. 

What should I do in order to retrieve all the data?

Thank you