Jump to content


Photo

Last Item in PickList Never Saved

picklist fields

  • Please log in to reply
2 replies to this topic

#1 varun21

varun21

    Newbie

  • New Members
  • Pip
  • 9 posts

Posted 14 May 2013 - 05:32 AM

I created a new field of the type picklist.

 

The last item in teh picklist never seems to get saved.

 

(Seems like a validation bug since by default the first item in picklist is empty, and maybe because of that we are onlysaving n-1 items?)

 

Tested on the demo installation of zurmo on zurmo.org and local install as well as our production install.



#2 Stafford

Stafford

    Zurmo Member

  • Moderators
  • 212 posts

Posted 14 May 2013 - 10:32 AM

Hey Varun,

 

Could you please submit a screenshot?

Thanks



#3 Damien Wilson

Damien Wilson

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 07 June 2013 - 10:46 PM

Hi there,

Was this ever resolved?

I have this bug too and found a work-around but also more troubling, the pick list won't show any more that 5 items in the dropdown. It's proving quite troublemsome.

The pick list in question is a dependable, custom extension of the Type pick list. I.e. when Vendor is selected show a selection of categories for that vendor.

ORIGINAL ISSUE WORKED AROUND - point 1 below

NO MORE THAN 5 SOLVED - point 4 below.

Some server info:

  • Zurmo is installed on an in-house Linux VM running Ubuntu 12.04.
  • The envornment is set up according to recommendations
  • The only package not installed is LDAP

To date I have tried:

  1. Adding an empty list item after the last and saving - this solved the last item not saved issue
  2. Running clearCache=1 after saving pick list
  3. Removing the pick list from the layout designer, saving, and then adding it again
  4. Opening the Type pick list and mapping new child list items to respective parents. SOLVES THE ISSUE

Damien







Also tagged with one or more of these keywords: picklist, fields

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users