Jump to content


Photo

Why is zurmo still using the deprecated mysql php extension?

mysql mysqli pdo php

  • Please log in to reply
2 replies to this topic

#1 sica07

sica07

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 28 November 2016 - 12:15 PM

Hi!

 

I noticed that in some classes, zurmo is still using the deprecated and insecure MySql extension.

For example, in the app/protected/core/DatabaseCompatibilityUtil.php all the connections to the mysql database are handled with this extension (mysql_connect()).

Is there a particular reason why this extension is favored instead of PDO, or, at least MySQLi? 



#2 Boban Perić

Boban Perić

    Zurmo Engineer

  • Administrators
  • 23 posts

Posted 28 November 2016 - 01:53 PM

Hi,

 

these mysql functions will be replaced by mysqli functions as of 3.2.0.



#3 sica07

sica07

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 29 November 2016 - 07:59 AM

Great to hear that!

I already replaced the mysql function with mysqli in the DatabaseCompatibilityUtil.php. Should I commit this changes to the zurmo repo?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users