Jump to content


Photo

Installation fails: mysql/access denied

mysql ubuntu 12.04 zurmo 2.0.6

  • Please log in to reply
5 replies to this topic

#1 jozsef

jozsef

    Newbie

  • New Members
  • Pip
  • 3 posts

Posted 26 June 2013 - 08:48 PM

Hi all,
Trying to install the latest stable version on ubuntu 12.04 vps. I got stuck at the sql parameters page. The way i see i have two options:
1) let the setup do the db settings
2) i set up db&user
If i go ahead with no.1. (give the root usernam&password) the installation starts but instantly dies with error message:

 

An error has occurred. Please click here to continue to the home page. If the error persists please contact your administrator.
SQLSTATE[28000] [1045] Access denied for user 'zurmo4'@'localhost' (using password: YES)
The reference id for this error is 0793274b551f4f90ac570427d50648a0.

 

When chosing no.2. (I pre-setup thing via phpmyadmin) i can't even start the installation, as right under the "Database Username" it says: 

 

Error code: 1045
Message: Access denied for user 'zurmo'@'localhost' (using password: YES)

 

 

Anyone seen anything like it? Any tips?

 

I tried looking up /var/log/mysql/error.log but no further info whatsoever...

 

Cheers,

jozsef

 



#2 speixoto

speixoto

    Advanced Member

  • Members
  • PipPipPip
  • 268 posts

Posted 26 June 2013 - 09:51 PM

Try checking your db user privileges. Add all privileges for user @localhost



#3 jozsef

jozsef

    Newbie

  • New Members
  • Pip
  • 3 posts

Posted 26 June 2013 - 10:11 PM

thanks for quick reply. when it first failed with all privileges granted for the db, i tried adding all privileges for localhost, but no change unfortunately :(

is there any way to enable debugging for the installation process?



#4 speixoto

speixoto

    Advanced Member

  • Members
  • PipPipPip
  • 268 posts

Posted 26 June 2013 - 11:06 PM

Can you please confirme with did not setted host using '%' but you explicied put 'localhost'. I used to have problems in Ubuntu using '%' as host.

 

And if you didnt tried it yeat, using the root user of mysql to make the connection.



#5 jozsef

jozsef

    Newbie

  • New Members
  • Pip
  • 3 posts

Posted 27 June 2013 - 05:57 AM

Can you please confirme with did not setted host using '%' but you explicied put 'localhost'. I used to have problems in Ubuntu using '%' as host.

 

And if you didnt tried it yeat, using the root user of mysql to make the connection.

 

huh, i'd have never thought of that... using the root user to make the connections seems to work. on the other hand im not sure whether it is a supported way to do this, but now it works. im wondering what might have caused to problem, tho.

thanks!



#6 speixoto

speixoto

    Advanced Member

  • Members
  • PipPipPip
  • 268 posts

Posted 27 June 2013 - 06:30 AM

The problem is a permissons one. My sugestion is to remove the zurmo users and create a new one but make sure you explicit put 'localhost' when adding permissons for zurmo db.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users