Jump to content


Photo

Email Configuration with GMAIL SMTP


  • Please log in to reply
14 replies to this topic

#1 tiurlg

tiurlg

    Member

  • Members
  • PipPip
  • 23 posts

Posted 12 July 2012 - 02:47 AM

Hi,

We tried to configure the Outbound Email configuration with this parameters :
host : smtp.gmail.com
port : 587
username : username@ourcompany.com

When we send test email it would give error :
Message failed to send
Error Code: 0
Error Message: Expected response code 250 but got code "530", with message "530 5.7.0 Must issue a STARTTLS command first. gh9sm2847345pbc.20

And if we change the port to : 25 or 465, the error message :
Message failed to send
Error Code: 0
Error Message: Connection could not be established with host smtp.gmail.com [Connection timed out #110]


Can anyone inform us how to set the outbound email configuration using gmail account?

#2 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 12 July 2012 - 08:48 AM

There was no way to set encryption type in outbound SMTP settings, and I fixed this issue, by allowing admins to enter encryption type(allowed values are '', 'ssl' and 'tls'). This code will be part of next Zurmo stable release(which we will release in next few days), but if you are using Mercurial you can get current bleeding version of Zurmo and be able to use Gmal SMTP server.

#3 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 12 July 2012 - 08:56 AM

One more thing, about Google SMTP ports/encryption. Port is related to encryption which you are using, so if you are using 'ssl' you must use port 465, and if you are using 'tls' encryption, you must use port 587.

#4 tiurlg

tiurlg

    Member

  • Members
  • PipPip
  • 23 posts

Posted 07 August 2012 - 02:23 PM

This is a working configuration for GMAIL SMTP Setting in Zurmo 7.1

Host : smtp.gmail.com
port : 465
username : email1@companyname.com
password : ****
extra mail settings : ssl (need to be in lower case "ssl", not "SSL")

#5 anil.kumar

anil.kumar

    Newbie

  • New Members
  • Pip
  • 3 posts

Posted 02 April 2013 - 01:27 PM

Hi Ivica,

 

I am having problem in email "Outbound Email Configuration (SMTP)", i follow all steps that mention in this discussion. but i still have the following error when sent test mail.

 

Error:
 

Message failed to send
Error Code: 0
Error Message: Failed to authenticate on SMTP server with username "anil.ex2k@gmail.com" using 2 possible authenticators

 

 

Please help me how to resolve this issue.

 

its very urgent bcoz this application is live and employee using. please help me...



#6 JotaLillo

JotaLillo

    Newbie

  • New Members
  • Pip
  • 5 posts

Posted 02 April 2013 - 01:39 PM

Hi Ivica,

 

I am having problem in email "Outbound Email Configuration (SMTP)", i follow all steps that mention in this discussion. but i still have the following error when sent test mail.

 

Error:
 

Message failed to send
Error Code: 0
Error Message: Failed to authenticate on SMTP server with username "anil.ex2k@gmail.com" using 2 possible authenticators

 

 

Please help me how to resolve this issue.

 

its very urgent bcoz this application is live and employee using. please help me...

 

Anil:

 

This is my setup for using Gmail mailings. In my case, I use my Google Apps account, but the setup is exactly the same as Gmail.
 
Works seamlessly to the latest stable version of Zurmo.
 
Important: Remember to send mails automatically must have properly configured the CRON for send mails.


#7 anil.kumar

anil.kumar

    Newbie

  • New Members
  • Pip
  • 3 posts

Posted 02 April 2013 - 04:02 PM

Thanks JotaLillo,

 

I am using zurmo-stable-1.0.20.46, and i also use the same for gmail,  but its not working. Can you please tell me proper steps how to do resolve this. and you said "properly configured the CRON for send mails", can you please tell me how to do this.

 

Thanks,



#8 anil.kumar

anil.kumar

    Newbie

  • New Members
  • Pip
  • 3 posts

Posted 04 April 2013 - 03:27 AM

Please anyone please help me, how to resolve the following error:

 

Error:
Message failed to send
Error Code: 0
Error Message: Failed to authenticate on SMTP server with username "anil.ex2k@gmail.com" using 2 possible authenticators

 

I am getting this error when sent test mail.



#9 daniel.mcdowell

daniel.mcdowell

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 23 April 2013 - 01:20 AM

This is the same error message I get any help?



#10 miguel84

miguel84

    Member

  • New Members
  • PipPip
  • 16 posts

Posted 06 May 2013 - 03:06 AM

This is the same error message I get any help?

I'm also getting this error on 1.6

 

how to fix?



#11 varun21

varun21

    Newbie

  • New Members
  • Pip
  • 9 posts

Posted 14 May 2013 - 03:15 AM

I can confirm that Google Apps email works as per Newbie's post above. And I'm using Zurmo 1.6.



#12 Ross

Ross

    Advanced Member

  • Administrators
  • 53 posts
  • LocationBuenos Aires

Posted 21 May 2013 - 01:31 PM

To use a GMail account for outbound smtp from Zurmo you should use the following credentials, replacing the specifics with the details of your own GMail account of course.

Host: smtp.gmail.com

Username: myaccount@gmail.com

Password: *****

Extra Mail Settings: ssl

Port: 465

If you receive the following message when attempting to send a test email then the issue is that Gmail has blocked access from your server IP address believing the  sign-in attempt to be a hijacker trying to access your account.

"Message failed to send
Error Code: 0
Error Message: Failed to authenticate on SMTP server with username "ross.peetoom@gmail.com" using 2 possible authenticators
"

Check your Gmail inbox, you have likely received an email from no-reply@accounts.google.com saying that "Someone recently tried to use an application to sign in to your Google Account".  You should scroll to the bottom of the email and follow the link to complete the troubleshooting steps.  On the page that loads follow the link "https://accounts.goo...ayUnlockCaptcha" and click the "Continue" button, you will now see the following text.

"Sign in using the application you want to authorize access to your account within the next ten minutes. Google will remember the application after it signs in, and will allow it to access your account in the future as long as it uses the correct password."

Restart your browser and log back into Zurmo, now test your SMTP settings again.  This time Gmail should accept the connection and your test mail should be delivered.


Ross Peetoom
Zurmo Team
Ross@zurmo.com

#13 MatthewJones

MatthewJones

    Member

  • Members
  • PipPip
  • 14 posts

Posted 30 September 2013 - 05:26 AM

I know this thread is old, but I wanted to add something for future users who are having issues getting Google Apps to work. 

 

I was having repeated issues with getting Zurmo to connect to the Google Apps SMTP server, even after following the instructions in this thread. It could connect to the local SMTP server just fine. It was only Google that was the problem. 

 

I was getting Error #110, which basically said "The server can't be reached". I don't remember the exact message. 

 

What I realized was that my firewall was blocking outgoing connections on Port #465. I went into my firewall settings, unblocked it, and it worked like magic! :-)

 

Anyway... I thought I'd post it as a suggestion here just in case anyone else runs into the same issue. 



#14 kavlito

kavlito

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 23 August 2015 - 04:44 PM

I know this is an old topic, but this does not work.  I have POP and IMAP both enabled in my Google Apps account and have used your settings, and used the:

 

https://accounts.goo...ayUnlockCaptcha

 

which confirms:

Account access enabled

Please try signing in to your Google account again from your new device or application.

 

But I still continue to get the error:

 

Message failed to send
Error Code: 0
Error Message: Failed to authenticate on SMTP server with username "user@gmail.com" using 2 possible authenticators

 

I've tried ssl and tls with the appropriate ports and still no resolution.

 

If there is no resolve to this, I won't be able to use Zurmo.

 

Thanks.

Attached Thumbnails

  • 2015-08-23 12_37_32-Start.jpg


#15 turbo2ltr

turbo2ltr

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 06 April 2017 - 01:54 PM

I'll add for the sake of others looking, for those of you getting a timeout error..

 

I am running Zurmo on a cpanel server (dedicated) with CSF/LFD running.  By default, to reduce the possibility of relaying spam, the server will not allow outgoing connections to other SMTP servers except by root and cpanel users. This threw me off because I tested the connection to gmail's smtp from a root ssh window and it worked, so I couldn't understand why it wouldn't work in Zurmo.

 

YMMV on a shared hosting environment, but if you have WHM access, you can go into ConfigServer Security & Firewall, click Firewall Settings, find the SMTP Settings area, and add the username of the account Zurmo is running under in the SMTP_ALLOW_USER

 

 

Also Ross's post above is a little outdated. For those of you getting the "Failed to authenticate on SMTP server with username "xxxx" using 2 possible authenticators", Follow the link in the security email that gmail sends you for "allow less secure apps" and turn that on.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users