Jump to content


Photo

Changes to Contact Status breaks Leads Module

leads contact status

  • Please log in to reply
8 replies to this topic

#1 egb

egb

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 14 November 2013 - 10:38 PM

There appears to be a bug with the Contact Status field and the Leads Module.  It appears that if you make any changes to the Status field, you will no longer be able to manually create Leads.

 

What was done

Brand new install of Zurmo on a Windows machine.

Created several new Contact/Lead fields. All of which worked fine with no negative affects on the Leads module.

Added an option to the Contact Status field called 'Prospect' and positioned it below 'In Progress'

Tried to create a Lead, received this error. 

 

"An error has occurred. Please click here to continue to the home page. If the error persists please contact your administrator.  The reference id for this error is ab614ac3467d4b6d8fa0e7ec6089c1e9."

 

Troubleshooting

Removed the added option, the error still occurs when creating a lead.

Setup a new instance of Zurmo and recreated the status option - breaks lead creation.

Tested on the demo version online - works fine.

 

Not sure where the issue is coming from and if it is isolated to Windows installations.  Next step I will try is setting up a Linux instance and hope that the bug does not return.

 

Any help would be appreciated.

 

Gary.



#2 raysto

raysto

    Zurmo Team

  • Administrators
  • 1,973 posts

Posted 15 November 2013 - 08:24 PM

If you make add a Contact status into a Lead status, then you will break it. Make sure Lead Statuses are really lead statuses and Contact statuses really contact statuses.
Lead_Contact_Status.png


Ray Stoeckicht
Zurmo Team
Try Zurmo Pro


#3 egb

egb

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 17 November 2013 - 09:05 PM

Can you further explain?  How would one make a Contact status into a Lead status?   

 

From what I understand, any status option above what is set as the Starting Status (ie: Qualified), is a Lead Status.  Any anything below, is a Contact Status.

 

All I have done is add a new option and placed it at the top of the list, making it a Lead Status.  

 

Can you advise on how I can correct this issue without having to start over with a brand new install?



#4 egb

egb

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 17 November 2013 - 09:19 PM

This is what the Application Log details when the error occurs:

 

 

2013/11/17 13:18:56 [error] [exception.NotSupportedException] exception 'NotSupportedException' in /var/www/html/zurmo/app/protected/core/models/RedBe
anModel.php:1398
Stack trace:
#0 /var/www/html/zurmo/app/protected/modules/zurmo/models/Item.php(98): RedBeanModel->__set('latestActivityD...', '')
#1 /var/www/html/zurmo/app/protected/modules/zurmo/models/SecurableItem.php(453): Item->__set('latestActivityD...', '')
#2 /var/www/html/zurmo/app/protected/modules/zurmo/models/OwnedSecurableItem.php(169): SecurableItem->__set('latestActivityD...', '')
#3 /var/www/html/zurmo/app/protected/core/models/RedBeanModel.php(2825): OwnedSecurableItem->__set('latestActivityD...', '')
#4 /var/www/html/zurmo/app/protected/modules/zurmo/utils/ZurmoControllerUtil.php(132): RedBeanModel->setAttributes(Array)
#5 /var/www/html/zurmo/app/protected/modules/zurmo/utils/ZurmoControllerUtil.php(108): ZurmoControllerUtil->saveModelFromSanitizedData(Array, Object(C
ontact), false, NULL, false)
#6 /var/www/html/zurmo/app/protected/modules/zurmo/components/ZurmoBaseController.php(738): ZurmoControllerUtil->saveModelFromPost(Array, Object(Conta
ct), false, NULL)
#7 /var/www/html/zurmo/app/protected/modules/leads/controllers/DefaultController.php(142): ZurmoBaseController->attemptToSaveModelFromPost(Object(Cont
act))
#8 /var/www/html/zurmo/yii/framework/web/actions/CInlineAction.php(49): LeadsDefaultController->actionCreate()
#9 /var/www/html/zurmo/yii/framework/web/CController.php(308): CInlineAction->runWithParams(Array)
#10 /var/www/html/zurmo/yii/framework/web/filters/CFilterChain.php(133): CController->runAction(Object(CInlineAction))
#11 /var/www/html/zurmo/yii/framework/web/filters/CFilter.php(40): CFilterChain->run()
#12 /var/www/html/zurmo/yii/framework/web/filters/CFilterChain.php(130): CFilter->filter(Object(CFilterChain))
#13 /var/www/html/zurmo/yii/framework/web/filters/CFilter.php(40): CFilterChain->run()
#14 /var/www/html/zurmo/yii/framework/web/filters/CFilterChain.php(130): CFilter->filter(Object(CFilterChain))
#15 /var/www/html/zurmo/yii/framework/web/filters/CFilter.php(40): CFilterChain->run()
#16 /var/www/html/zurmo/yii/framework/web/filters/CFilterChain.php(130): CFilter->filter(Object(CFilterChain))
#17 /var/www/html/zurmo/yii/framework/web/CController.php(291): CFilterChain->run()
#18 /var/www/html/zurmo/yii/framework/web/CController.php(265): CController->runActionWithFilters(Object(CInlineAction), Array)
#19 /var/www/html/zurmo/yii/framework/web/CWebApplication.php(282): CController->run('create')
#20 /var/www/html/zurmo/yii/framework/web/CWebApplication.php(141): CWebApplication->runController('leads/default/c...')
#21 /var/www/html/zurmo/yii/framework/base/CApplication.php(169): CWebApplication->processRequest()
#22 /var/www/html/zurmo/app/protected/core/components/WebApplication.php(75): CApplication->run()
#23 /var/www/html/zurmo/app/index.php(70): WebApplication->run()
#24 {main}
REQUEST_URI=/zurmo/app/index.php/leads/default/create


#5 raysto

raysto

    Zurmo Team

  • Administrators
  • 1,973 posts

Posted 18 November 2013 - 04:00 AM

We have Developer Sessions every Tuesday at 10:00AM Chicago Time (http://zurmo.org/forums/index.php?/calendar/event/2-developer-learning-session/). You can always join an upcoming session and ask any questions to our technical team.


Ray Stoeckicht
Zurmo Team
Try Zurmo Pro


#6 Jason

Jason

    Administrator

  • Administrators
  • 864 posts
  • LocationChicago

Posted 07 April 2014 - 12:40 AM

i made a bug for this 

https://www.pivotalt...y/show/68204998


Jason Green
Zurmo Team
Need support? Upgrade now


#7 Jason

Jason

    Administrator

  • Administrators
  • 864 posts
  • LocationChicago

Posted 07 April 2014 - 12:44 AM

I can't replicate this in the latest installation. Are you able to replicate this in our demo environment here: http://demo.zurmo.co...o/default/login


Jason Green
Zurmo Team
Need support? Upgrade now


#8 Jason

Jason

    Administrator

  • Administrators
  • 864 posts
  • LocationChicago

Posted 13 April 2014 - 12:34 PM

Can anyone replicate this?


Jason Green
Zurmo Team
Need support? Upgrade now


#9 midhunface

midhunface

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 31 October 2014 - 05:23 PM

Hi,
when i tried to import a CSV file, I mapped Category field in CSV with Status Zurmo field. It is showing an error "Category field is invalid". So all files are skipped.
Please advise me on this.
 
Thank you

Attached Thumbnails

  • import_status_error_1.png






Also tagged with one or more of these keywords: leads, contact, status

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users