Jump to content


Install stuck with nothing written to database: No errors

install database infinite loop

  • Please log in to reply
2 replies to this topic

#1 JMOmandown



  • Members
  • Pip
  • 3 posts

Posted 25 December 2013 - 12:01 AM

Environment Information

Centos:                5.9 x86_64

WHM/Cpanel:      11.40.1

Apache:               2.2.26

PHP:                    5.4.23

MySQL:               5.5


Memcache and APC not installed.  PHP set to use FCGI under MPM Worker.



Zurmo's install page loads properly with no errors and proceeds through the system check successfully.  When entering the various database information into the next page and hitting install, the process seems to be stuck in an infinite loop.  Nothing is written to the database (although the ability to connect has been confirmed) and there is nothing outputted to the error log on the system or in Zurmo.


To try a different approach, we have also tried installing Zurmo through helper modules as opposed to directly.  I am pretty sure this is an environment issue as when Zurmo is installed via a helper module like Installeron, it installs properly, but no users (including the superuser) can login.  I suspect this also would be because the system is not properly connecting to the database like when Zurmo is installed directly.  I prefer not to install a helper module to install or update Zurmo.


I am really at a loss for where to go or what to try without any error output information.  I have checked the permissions of all folders per the setup requirements and also tried setting them all to permission 777 just to be sure.  We have tried Zurmo with and without memcache, but never received the common error that a particular class cannot be found nor could we get it working.


Just for kicks I have installed SugarCRM to see if the environment was blocking everything but that installed and functioned correctly.  We really love where Zurmo is trying to take the CRM concept and would like to be along for the ride, but I am unsure how to proceed here.  I have read through the forums for several days now without finding a solution.  Any ideas are more than appreciated.

#2 JMOmandown



  • Members
  • Pip
  • 3 posts

Posted 26 December 2013 - 10:26 PM

Got a chance to take another look today and randomly started getting an error_log being properly generated, so there must have been some sort of cache thing going on.


The error is the standard Class 'SecurableModule' not found, indicating a permission setting problem.  I have double checked these according to the various topics throughout the forums.  The permissions are set properly.


It seems reading around that often there can be an issue with the ownership of the folder's or some other environment setup issue.  The general requirements are met and everything is setup as specified, so how do I proceed to identify and fix the issue from here?


Updated Symptoms:

  • Standard Class 'SecurableModule' not found
  • Proper Permissions on Folders are set
  • Environment meets requirements
  • Logging in just has the thumber spin infinitely and the SecurableModule error is written to error_log

Solutions Attempted

#3 JMOmandown



  • Members
  • Pip
  • 3 posts

Posted 27 December 2013 - 05:46 AM

To address the SecurableModule not found issue and see if there is truly a permission issue present as is often the suggested solution we have replaced line 421 of YiiBase.php  with the following:

switch ($className)
case 'SecurableModule':
	include ($_SERVER['DOCUMENT_ROOT'] . '/zurmo/app/protected/modules/zurmo/modules/' . $className . '.php');

case 'Module':
	include ($_SERVER['DOCUMENT_ROOT'] . '/zurmo/app/protected/core/modules/' . $className . '.php');

case 'ZurmoBaseController':
	include ($_SERVER['DOCUMENT_ROOT'] . '/zurmo/app/protected/modules/zurmo/components/' . $className . '.php');

case 'Controller':
	include ($_SERVER['DOCUMENT_ROOT'] . '/zurmo/app/protected/core/controllers/' . $className . '.php');

case 'WebUser':
	include ($_SERVER['DOCUMENT_ROOT'] . '/zurmo/app/protected/modules/zurmo/components/' . $className . '.php');

case 'RedBeanDatabase':
	include ($_SERVER['DOCUMENT_ROOT'] . '/zurmo/app/protected/core/models/' . $className . '.php');

case 'ZurmoRedBean':
	include ($_SERVER['DOCUMENT_ROOT'] . '/zurmo/app/protected/core/models/' . $className . '.php');

	include ($className . '.php');

Providing the absolute path eliminated all errors about not finding particular classes or files.  Although I am aware this is not the intended way Zurmo should run, it does show that permissions/access is not the issue.  No errors in the error log now, but still have an infinite sign in loop where nothing happens.


Upon checking the application.log in the runtime folder, we now get the following exception:

2013/12/27 10:01:11 [error] [exception.CHttpException.400] exception 'CHttpException' with message 'The CSRF token could not be verified.' in root/path/zurmo/yii/framework/web/CHttpRequest.php:1042
Stack trace:
#0 root/path/zurmo/app/protected/core/components/ZurmoHttpRequest.php(47): CHttpRequest->validateCsrfToken(Object(CEvent))
#1 root/path/zurmo/yii/framework/base/CComponent.php(558): ZurmoHttpRequest->validateCsrfToken(Object(CEvent))
#2 root/path/zurmo/yii/framework/base/CApplication.php(196): CComponent->raiseEvent('onBeginRequest', Object(CEvent))
#3 root/path/zurmo/yii/framework/base/CApplication.php(167): CApplication->onBeginRequest(Object(CEvent))
#4 root/path/zurmo/app/protected/core/components/WebApplication.php(75): CApplication->run()
#5 root/path/zurmo/app/index.php(70): WebApplication->run()
#6 {main}

Any thoughts?

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users