Jump to content


Photo

Installation Fails


  • Please log in to reply
8 replies to this topic

#1 Andre

Andre

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 20 October 2012 - 10:19 PM

I am getting the following message:

Database default collation is: utf8_general_ci . Database default collation should not be in: utf8_general_ci

This is on Windows 2008 server with the latest stable version. I found other posts on forums as well as installation instructions, updated the my.ini file, restarted the server, tried everything I can, changing the character sets etc, but it just does not work.

Any suggestions?

Thanks

#2 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 22 October 2012 - 07:06 AM

Change mysql database collation to utf8_unicode_ci and you should be able to install Zurmo.
Add next code in my.ini file:
character-set-server=utf8
collation-server=utf8_unicode_ci



#3 Andre

Andre

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 22 October 2012 - 04:16 PM

Hi,

I tried that already in every possible combination, under mysql only, under mysqld only, under both of them, even I created a schema called zurmo, and assigned this to be its default collation. Nothing worked.

I even tried editing the file
DatabaseDefaultCollationServiceHelper.php
Changing $passed = false to true which got me to another screen but with errors.

What I do not understand here apart from the error message is
protected $notAllowedDatabaseCollations = array('utf8_general_ci');

It seems that utf8_general_ci is not allowed, so I don't understand why you insist in this thread and others to use it
(I did try even latin1 but it failed with the same error)

I do restart the mysql server each time I make the change.

What else can I do?

Thanks.

#4 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 23 October 2012 - 06:55 AM

http://zurmo.org/for...-mycnf-ignored/
http://zurmo.org/wik...for-development

We require default collation to be set to utf8_unicode_ci, because some issue we had with general collation(I can't remember which issues we had). After you made changes(in mysqld section), you can check default collation:

SELECT DEFAULT_COLLATION_NAME FROM information_schema.SCHEMATA WHERE SCHEMA_NAME = 'zurmo'
or
show variables like "%collation_server%"

Results shouldn't have utf8_general_ci

#5 Andre

Andre

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 23 October 2012 - 08:42 PM

I am confused

I saw this tread (http://zurmo.org/for...-mycnf-ignored/) where you said
Under [mysql] section add line:
default-character-set=utf8

Then under [mysqld] you should have next two lines:
character-set-server=utf8
collation-server=utf8_unicode_ci

In the other thread(http://zurmo.org/wik...for-development), which I also tried there is this
  • Add next lines under [mysqld] section:
  • character-set-server=utf8
  • collation-server=utf8_unicode_ci



In this thread (at the top) you said


character-set-server=utf8


collation-server=utf8_unicode_ci



And also
We require default collation to be set to utf8_unicode_ci
Results shouldn't have utf8_general_ci

Anyway I run
SELECT DEFAULT_COLLATION_NAME FROM information_schema.SCHEMATA WHERE SCHEMA_NAME = 'zurmo'
and it returned
utf8_general_ci

Anyway I got it to return the correct result with:
Then under [mysqld] you should have next two lines:
character-set-server=utf8
collation-server=utf8_unicode_ci

and managed to get installation to pass to the next page
On the next page I got this:

PHP warning

date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/London' for '1.0/DST' instead



C:\inetpub\wwwroot\crm\app\protected\core\utils\DateTimeUtil.php(135)



123 }
124
125 public static function convertTimestampToDbFormatDate($timestamp)
126 {
127 assert('is_int($timestamp)');
128 return Yii::app()->dateFormatter->format(DatabaseCompatibilityUtil::getDateFormat(),
129 $timestamp);
130 }
131
132 public static function convertTimestampToDbFormatDateTime($timestamp)
133 {
134 assert('is_int($timestamp)');
135 $timeZone = date_default_timezone_get();
136 date_default_timezone_set('GMT');
137 $result = Yii::app()->dateFormatter->format(DatabaseCompatibilityUtil::getDateTimeFormat(),
138 $timestamp);
139 date_default_timezone_set($timeZone);
140 return $result;
141 }
142
143 public static function convertDbFormatDateTimeToTimestamp($dbFormatDateTime)
144 {
145 assert('is_string($dbFormatDateTime)');
146 $timeZone = date_default_timezone_get();
147 date_default_timezone_set('GMT');



Stack Trace
#0

[/center] C:\inetpub\wwwroot\crm\app\protected\core\utils\DateTimeUtil.php(135): date_default_timezone_get()

130 }
131
132 public static function convertTimestampToDbFormatDateTime($timestamp)
133 {
134 assert('is_int($timestamp)');
135 $timeZone = date_default_timezone_get();
136 date_default_timezone_set('GMT');
137 $result = Yii::app()->dateFormatter->format(DatabaseCompatibilityUtil::getDateTimeFormat(),
138 $timestamp);
139 date_default_timezone_set($timeZone);
140 return $result;
#1

[/center] C:\inetpub\wwwroot\crm\app\protected\modules\zurmo\models\Item.php(54): DateTimeUtil::convertTimestampToDbFormatDateTime(1351024539)

49 $this->insideOnModified = true;
50 if (!($this->unrestrictedGet('id') < 0 &&
51 $this->getScenario() == 'importModel' &&
52 array_key_exists('modifiedDateTime', $this->originalAttributeValues)))
53 {
54 $this->unrestrictedSet('modifiedDateTime', DateTimeUtil::convertTimestampToDbFormatDateTime(time()));
55 }
56 if (Yii::app()->user->userModel != null && Yii::app()->user->userModel->id > 0)
57 {
58 if (!($this->unrestrictedGet('id') < 0 &&
59 $this->getScenario() == 'importModel' &&
#2

[/center] C:\inetpub\wwwroot\crm\app\protected\core\models\RedBeanModel.php(1320): Item->onModified()

1315 else
1316 {
1317 if ($this->unrestrictedSet($attributeName, $value))
1318 {
1319 $this->modified = true;
1320 $this->onModified();
1321 }
1322 }
1323 }
1324
1325 /**
#3

+

[/center] C:\inetpub\wwwroot\crm\app\protected\modules\zurmo\models\Item.php(78): RedBeanModel->__set("timeZone", "UTC")
#4

+

[/center] C:\inetpub\wwwroot\crm\app\protected\core\validators\RedBeanModelDefaultValueValidator.php(88): Item->__set("timeZone", "UTC")
#5

+

[/center] C:\inetpub\wwwroot\crm\yii\framework\validators\CValidator.php(214): RedBeanModelDefaultValueValidator->validateAttribute(User, "timeZone")
#6

+

[/center] C:\inetpub\wwwroot\crm\app\protected\core\models\RedBeanModel.php(848): CValidator->validate(User)
#7

+

[/center] C:\inetpub\wwwroot\crm\app\protected\core\models\RedBeanModel.php(429): RedBeanModel->runDefaultValidators()
#8

+

[/center] C:\inetpub\wwwroot\crm\app\protected\modules\install\utils\InstallUtil.php(563): RedBeanModel->__construct()
#9

+

[/center] C:\inetpub\wwwroot\crm\app\protected\modules\install\utils\InstallUtil.php(847): InstallUtil::createSuperUser("super", "Faca1706")
#10

+

[/center] C:\inetpub\wwwroot\crm\app\protected\modules\install\controllers\DefaultController.php(130): InstallUtil::runInstallation(InstallSettingsForm, MessageStreamer)
#11

+

[/center] C:\inetpub\wwwroot\crm\app\protected\modules\install\controllers\DefaultController.php(104): InstallDefaultController->actionRunInstallation(InstallSettingsForm)
#12

+

[/center] C:\inetpub\wwwroot\crm\app\protected\modules\install\controllers\DefaultController.php(82): InstallDefaultController->additionalSystemCheck(InstallSettingsForm)
#13

+

[/center] C:\inetpub\wwwroot\crm\yii\framework\web\actions\CInlineAction.php(50): InstallDefaultController->actionSettings()
#14

+

[/center] C:\inetpub\wwwroot\crm\yii\framework\web\CController.php(309): CInlineAction->runWithParams(array())
#15

+

[/center] C:\inetpub\wwwroot\crm\yii\framework\web\filters\CFilterChain.php(134): CController->runAction(CInlineAction)
#16

+

[/center] C:\inetpub\wwwroot\crm\yii\framework\web\filters\CFilter.php(41): CFilterChain->run()
#17

+

[/center] C:\inetpub\wwwroot\crm\yii\framework\web\filters\CFilterChain.php(131): CFilter->filter(CFilterChain)
#18

+

[/center] C:\inetpub\wwwroot\crm\yii\framework\web\CController.php(292): CFilterChain->run()
#19

+

[/center] C:\inetpub\wwwroot\crm\yii\framework\web\CController.php(266): CController->runActionWithFilters(CInlineAction, array(array("application.modules.install.controllers.filters.InstallControlle...")))
#20

+

[/center] C:\inetpub\wwwroot\crm\yii\framework\web\CWebApplication.php(283): CController->run("settings")
#21

+

[/center] C:\inetpub\wwwroot\crm\yii\framework\web\CWebApplication.php(142): CWebApplication->runController("install/default/settings")
#22

+

[/center] C:\inetpub\wwwroot\crm\yii\framework\base\CApplication.php(162): CWebApplication->processRequest()
#23

+

[/center] C:\inetpub\wwwroot\crm\app\protected\core\components\WebApplication.php(48): CApplication->run()
#24

+

[/center] C:\inetpub\wwwroot\crm\app\index.php(56): WebApplication->run()



Any ideas?

thanks

#6 Andre

Andre

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 23 October 2012 - 08:55 PM

After setting timezone in php.ini I got it working.

That was hard. You really need to make the installation easier. I hope the app will work well now.

Thanks,

Andre

#7 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 24 October 2012 - 12:17 PM

Great. You can try to make unit tests running, to ensure that everything work fine on your server.

#8 petewwa

petewwa

    Member

  • Members
  • PipPip
  • 13 posts

Posted 23 September 2013 - 10:41 AM

Here is how to get to get collation set on your database without having to modify the my.cnf

 

https://kb.mediatemp...nd collation#gs



#9 petewwa

petewwa

    Member

  • Members
  • PipPip
  • 13 posts

Posted 23 September 2013 - 10:44 AM

Zurmo installation is a bad experience!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users