Jump to content


Photo

[solved] Import bug in 0.7.60

import csv 0.70.60 bug

  • Please log in to reply
5 replies to this topic

#1 Sibo

Sibo

    Member

  • New Members
  • PipPip
  • 10 posts

Posted 26 October 2012 - 12:14 PM

I want to import a csv file with prospects to the leads table. But I get a internal error after adding the file. Below you will find a report from my error console. I think the new import Jquery js in Zurmo is the problem. Because i heard some roomers about a updated import script. The bug is in my own Zurmo 0.7.60 and in the demo on dev2.zurmo.com.

I hope someone can help me..
--
[14:04:33.026] NS_ERROR_NOT_IMPLEMENTED: Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIDOMLSProgressEvent.input] @ http://dev2.zurmo.co...m/1351226314:43
---

The second time I want to upload the file i also get a PHP Post error:
--
[14:36:17.871] POST http://dev2.zurmo.co...dForm_file&id=5 [HTTP/1.0 500 Internal Server Error 854ms]
---
<h1>PHP Error [2]</h1>
<p>fgetcsv() [<a href='function.fgetcsv'>function.fgetcsv</a>]: enclosure must be a character</p>
---
And then the same error as before!!


A workaround for me is to import it manually in MySQL or use a old version of Zurmo.
In the attachment file you find a demo.csv file with 500 records.

Kind regard,
Sibo

Attached Files

  • Attached File  500.zip   33.62KB   163 downloads


#2 Jason

Jason

    Administrator

  • Administrators
  • 864 posts
  • LocationChicago

Posted 27 October 2012 - 02:29 PM

Did you try this on the demo instance on our site and it also created an error? Can you confirm that?

Jason Green
Zurmo Team
Need support? Upgrade now


#3 Sibo

Sibo

    Member

  • New Members
  • PipPip
  • 10 posts

Posted 29 October 2012 - 09:27 AM

Did you try this on the demo instance on our site and it also created an error? Can you confirm that?


Hi Jason,

I try't also on the demo instance and i get the same error.
I used firefox and chromium, on both browsers it did not work.
You can try it yourself with the same demo data in the attachment file.

Kind regard,
Sibo


#4 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 30 October 2012 - 03:34 PM

Hi SIbo,
There was two issue with importing this file:
1. There was bug in Zurmo, and we fixed it in bleeding version of Zurmo, and this fix will be in next stable version
2. Your csv file is using MAC line endings, and php function fgetcsv have problems with importing csv files with MAC line endings, so you can either:
-save this file with Unix or Windows line enings
-set in php.ini file, to auto detect line endings(http://www.php.net/m...ion.fgetcsv.php)

Let us know if this solved this issue.

#5 Sibo

Sibo

    Member

  • New Members
  • PipPip
  • 10 posts

Posted 31 October 2012 - 09:35 AM

Hello Ivica,

I tested the bleeding version of Zurmo (Nightly built 2012-10-31 07:17:00 UTC) and the import works fine.
Thank you for the fast support. I can not wait for the stable version 0.8.0 to come.
Happy developing and keep up the good work, this is a fantastic open-source project!

Kind regard,
Sibo

#6 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 31 October 2012 - 01:32 PM

Yes, it is fixed in bleeding version, I pushed code few hours ago, and now it works with MAC OS line endings.





Also tagged with one or more of these keywords: import, csv, 0.70.60, bug

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users