Jump to content


Photo

Marketing sending problem & fix

marketing mails crons

  • Please log in to reply
2 replies to this topic

#1 johnt

johnt

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts

Posted 07 April 2014 - 05:55 AM

Hi,

 

ive been playing around with zurmo recently and noticed some strange things in marketing.

After searching the forums i found there have been at various times similar issues, so here is my issue, some basic fixes and current problems...

 

Issue:

Having a campaign of 800 people in the list leaves the campaign sending for days (not 100 every hour).

Crons setup as the help document found in zurmos site.

 

Temp fix:

Run the cron Process Campaign Messages.

zurmo seems to have 2 limits, process campaign messages and the cron which sends the emails. both seem to process 100 messages each. and process campaign seems to run once a day, effectively you are sending 100 mails a day if you leave it.

 

Current Problem:

Still exploring ways on prolonging the cron automatically and of increasing capacity of 100 messages, the settings are now uneditable.

 

Problem 2:

The marketing list has some really valuable data, such as opened, click etc but has a small list of just 5 entries and reports dont seem to work on it (or maybe i just havent figured it out yet), can we

1) increase the list size

2) add an aditional filter unopened to see who is not reading the emails so we can look at unsubscribing them permanently ourself?

3) save the status of read/clicked/unread in the lead so we can run further statistics on this data?

 

Thanks for the help!

J



#2 johnt

johnt

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts

Posted 08 April 2014 - 04:35 AM

ok so heres the updates so far... my theory on taking days is wrong for marketing...seems the cron on http://zurmo.org/wik...-up-job-manager did not include the crons for processcampaign. I used the cron from http://zurmo.org/forums/index.php?/topic/1721-cron-job-and-marketing-campaign-solved/ and just applied it. the monitor job seems to be running but the following jobs have now changed their last run status to never:

 

Process meetings for related records latest activity dates

Process by-time workflow rules

Read Permission Subscription Comprehensive Update Job

Read Permission Subscription Quick Update Job

Short Url Cleanup Job

 

lets see if processcampaign runs hourly now...

 

Pending issues still remain:

-increasing mailing capacity from 100

-All of Problem 2



#3 johnt

johnt

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts

Posted 11 April 2014 - 06:08 AM

campaigns seem to be working fine for now (tried a 30 person campaign)

however a strange event is noticed for large lists...

some contacts in the list were skipped with the message:

The message was not created.

 

What could this possibly mean..?

These contacts had email address in their email address 1 field







Also tagged with one or more of these keywords: marketing, mails, crons

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users