Jump to content


Photo

My installation experience, room for improvement

errors installation

  • Please log in to reply
3 replies to this topic

#1 radu

radu

    Member

  • Members
  • PipPip
  • 11 posts

Posted 17 November 2012 - 11:28 PM

*
POPULAR

The package looks great, and I am planning to march along the community and help out with what I can. So I hope my installation experience can lead to further improvement of the software.

Initial setup was simple: I downloaded the stable tar.gz (revision id : 03f2734b34d3) and extracted and configured under LAMP to have it running as http://zurmo.somedomain.com not as /zurmo/
I made sure to chown the directory and the content to the ftp user and apache group and chmod to 7 for ftp and 5 for http, for minimal security.

However, when I went to the root directory in the browser, i get:

Application runtime path ".../zurmo/app/protected/runtime" is not valid. Please make sure it is a directory writable by the Web server process.

and then:

zurmo/app/assets is not writable.
zurmo/app/protected/data is not writable.

I went chmod 775 on all those dirs and I managed to get to the first page of the installation process.

However, again, after going to next step (app/index.php/install/default/checkSystem) I got this:

copy(zurmo/app/protected/config/debug.php): failed to open stream: Permission denied

For security reasons, at this point I did chown apache:apache to have this step allowed, and then back to chown vftp:apache after the installation was done...


Yes, it was fairly easy for me, but might not be so trivial to others. At least for the .tar.gz package you could do the 775 (or 770, or 777 but preferably not) in the archive. Or instruct the users to temporarily chown the zurmo folder to the apache user during installation, although this won't solve the first 3 errors. Or something else, each user mileage may vary...

After that, everything went fine, at least for the installation process...
I had some big failures on the unstable installation, but now I am moving to stable to make sure they are not only due to the "unstable" flag...
I will be back with a separate post, if nobody is upset by this one, with my experience on the default installation, as a user...

If additional info is needed, let me know, I will comply.

#2 radu

radu

    Member

  • Members
  • PipPip
  • 11 posts

Posted 17 November 2012 - 11:33 PM

*
POPULAR

Ok, until I figure out what's wrong, it's worth mentioning that on the default installation (with sample data) , when I click go to the Dashboard and I get to /app/index.php/home/default I get a big no-no:


An error has occurred. Please click here to continue to the home page. If the error persists please contact your administrator.

Undefined offset: 0



#3 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 19 November 2012 - 06:38 AM

We will try to review and improve installation process before Zurmo GA release(beginning of December).

Now about your error, I suggested to turn on debuging in config/debug.php file, and send us more error details(Please note that you will need to clearCache, when you turn on debug, by appending query ?clearCache=1 to url that you try to access, only first time after debug is switched to on, to avoid model checking error).

#4 radu

radu

    Member

  • Members
  • PipPip
  • 11 posts

Posted 29 December 2012 - 12:04 AM

Now about your error, I suggested to turn on debuging in config/debug.php file, and send us more error details(Please note that you will need to clearCache, when you turn on debug, by appending query ?clearCache=1 to url that you try to access, only first time after debug is switched to on, to avoid model checking error).


Sorry for the delay, I should have helped you fix this before the release, but since it seams to be a very isolated issue, should be ok... Please note I am now using latest stable release.

Thanks for the pointers on debugging, although I chose Zurmo because it's done with YII, I completely forgot I should know how to debug an YII app.

So, here's more than just the debug info, here's the issue precisely pinned down.
First, the error:
Undefined offset: 0
... zurmo/app/protected/modules/users/models/User.php(394)
390					 $avatarUrl = "http://www.gravatar.com/avatar/?s={$size}&r=g&d=mm"; // Not Coding Standard
391				 }
392				 //Check connection to gravatar and return offline picture
393				 $htmlHeaders = get_headers($avatarUrl);
394				 if (preg_match("|200|", $htmlHeaders[0]))
395				 {
396					 $this->avatarImageUrl = $avatarUrl;
397				 }

For some reason, get_headers is an empty array after trying to call gravatar.com, so the preg_match fails.

For now, until it gets fixed, for me it works with a simple hack on line 394 :
394 if (isset($htmlHeaders) or preg_match("|200|", $htmlHeaders[0]))
I haven't tested the install anymore, let me know if it would help you, also do let me know if you need more info on my setup to help you understand why this happens.

regards
Radu.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users