Jump to content


Photo

[SOLVED] Important latencies loading pages in Zurmo (local server)

lag latency latencies page secondes loading local server

  • Please log in to reply
15 replies to this topic

#1 GahaBeen

GahaBeen

    Member

  • Members
  • PipPip
  • 14 posts

Posted 09 July 2014 - 07:50 AM

Hi,

 

We've installed the last version of Zurmo 2.7.3 a month ago on a dedicated server.

 

During the 2 first weeks, everything was fine. Switching between pages was realy quick and efficient.

 

But since 2 weeks, its impossible to use Zurmo because of important latencies: between 20 and 30 secondes to load a new page.

 

We have changed nothing during that month and I've only imported 380 client accounts.

 

We've used Memcache and Memcached but nothing changed. We've also try some ready-to-use versions on virtual machines but there is still a latency...

 

 

Do you have any idea about that kind of problem ?

 

 

Thank you very much for your help,

Have a good day.

 

GahaBeen

 

 



#2 speixoto

speixoto

    Advanced Member

  • Members
  • PipPipPip
  • 386 posts

Posted 09 July 2014 - 10:14 AM

What language are you using in the system? Are you behind some sort of firewall?



#3 GahaBeen

GahaBeen

    Member

  • Members
  • PipPip
  • 14 posts

Posted 09 July 2014 - 12:11 PM

- We are using English version. French one is also uploaded.

Zurmo was well working during 2 weeks with that settings.

 

- We don't have firewall on server side. We only have one on client side.

The problem is more a problem of performance thant a problem of server.

 

Now that I want to see the uploaded languages I discover that I have a problem accessing that configuration from that Zurmo address : http://ourservername...nfigurationList .

 

Here is the error that I've got:

simplexml_load_file(http://translate.zurmo.org/sites/default/files/l10n_packager/l10n_server.xml): 
failed to open stream: Connection timed out.
The reference id for this error is 4871c4c6ada84fddafa0a08cba70417f

It seems that this latency make failing that update of languages list.

 

Do you have any suggestion ?

 

Thank you !



#4 speixoto

speixoto

    Advanced Member

  • Members
  • PipPipPip
  • 386 posts

Posted 09 July 2014 - 01:43 PM

For me it seams the firewall. Try to turn client firewall off.



#5 GahaBeen

GahaBeen

    Member

  • Members
  • PipPip
  • 14 posts

Posted 10 July 2014 - 12:08 PM

It's changed nothing with a client firewall off.

 

We tried with 2 virtual machines found online:

- Officiel one (Zurmo) in 0.6.8 version : any latencies found.

- Bitnami with Zurmo in 2.7.2 : its much more slow than on our dedicated server

 

They've been tested on VirtualBox and VMWare Esxi5.1.

 

Any other suggestions ?



#6 speixoto

speixoto

    Advanced Member

  • Members
  • PipPipPip
  • 386 posts

Posted 10 July 2014 - 12:37 PM

 

It seems that this latency make failing that update of languages list.

 Well, there is some sort of problem between your comunication between your server and zurmo ones. Maybe this is causing the latency.



#7 GahaBeen

GahaBeen

    Member

  • Members
  • PipPip
  • 14 posts

Posted 10 July 2014 - 01:30 PM

That's what I was looking for and our IT service just found where was the problem..

 

They changed our dedicated server to an IP address with no access to internet. Using an IP open to internet makes working Zurmo \o/ !

 

Now the question is : "Can we use Zurmo without any access to internet ?".

 

Thank you for your help !



#8 speixoto

speixoto

    Advanced Member

  • Members
  • PipPipPip
  • 386 posts

Posted 10 July 2014 - 02:34 PM

The problem with working with no internet access is that you need to disable some connection to some services. The one i can remember from head is the ability to download translation files from the translate.zurmo.org server and the other one thing that you may need to do is disable the connection to gravatar that is used to render users avatar images (i think its here that resides your slowness problem when disabling internet access).

 

So, if you want to disable gravatar connection just go to the User.php file and make the getAvatarImageUrl return this and nothing else: Yii::app()->theme->baseUrl . '/images/offline_user.png';



#9 GahaBeen

GahaBeen

    Member

  • Members
  • PipPip
  • 14 posts

Posted 11 July 2014 - 09:27 AM

Hi,

 

I've commented the following lines in order to only have that one :

 

$this->avatarImageUrl = Yii::app()->theme->baseUrl . '/images/offline_user.png';
 

From the file: /var/www/zurmo/app/protected/modules/users/models/User.php

<?php

//...

//                 if (isset($this->avatarImageUrl))
//                 {
//                     $this->avatarImageUrl = $avatarUrl;
//                 }
//                 else
//                 {
                    // Check connection to gravatar and return offline picture
//                    $htmlHeaders = @get_headers('http:' . $avatarUrl);
//                     if (preg_match("|200|", $htmlHeaders[0]))
//                     {
//                         $this->avatarImageUrl = $avatarUrl;
//                     }
//                     else
//                     {
                        $this->avatarImageUrl = Yii::app()->theme->baseUrl . '/images/offline_user.png';
//                     }
//                 }

//...

?>

Main problem: latencies are still there :mellow:

It worked! IT department's just forgotten to comment a line. Gravatar was the source of lagging (with a local version, without internet).

 

Do you have any other ideas to get a complete offline Zurmo installation ?

 

Thank you very much for all your support,

Have a good day!

 

Gaha Been



#10 speixoto

speixoto

    Advanced Member

  • Members
  • PipPipPip
  • 386 posts

Posted 11 July 2014 - 01:17 PM

Can you use firebug (or any other frontend debugger) to check what calls are made when opening a zurmo page and are getting latency?



#11 GahaBeen

GahaBeen

    Member

  • Members
  • PipPip
  • 14 posts

Posted 15 July 2014 - 09:50 AM

I tried but we're lock with the rubish IE7.. I'll try to get an additional debug tool and come back to you.

#12 GahaBeen

GahaBeen

    Member

  • Members
  • PipPip
  • 14 posts

Posted 15 July 2014 - 01:36 PM

No way to find where is coming the failed connections...

 

I'll try to get an "online" IP from our IT departement and that will be fine like this I think.



#13 GahaBeen

GahaBeen

    Member

  • Members
  • PipPip
  • 14 posts

Posted 16 July 2014 - 07:14 AM

For confidentiality reason, I must indicate which internet addresses (domain names) I can allow to Zurmo to access.

 

What are the server that Zurmo needs (to avoid latencies) ? I couldn't define by my one what are the connection with external servers..

 

Servers required detected:

 

- http://zurmo.org (http://translate.zurmo.org)

- http://gravatar.com (its not for me because I shunt it normaly with your advice)

 

Some others ?



#14 speixoto

speixoto

    Advanced Member

  • Members
  • PipPipPip
  • 386 posts

Posted 16 July 2014 - 07:30 AM

translate.zurmo.org for the languages

gravatar.com for the user pics

 

I cant remember another that will be needed, you should maybe check the blocked connections from your side.



#15 GahaBeen

GahaBeen

    Member

  • Members
  • PipPip
  • 14 posts

Posted 16 July 2014 - 08:55 AM

Please see above the right solution if you want to use Zurmo on a local server (without any access to internet).

 

As speixoto adviced me, it was Gravatar.

 

Now, as I want to use the Google Maps pluggin and I want to be able to change language (needs access to zurmo.org server), lI will use an IP address with restricted internet access (with still no needs for Gravatar).

 

Thank you very much for all your time and your support speixoto !

 

Long life to Zurmo :) 

 

Regards,

 

GahaBeen



#16 jameswtc

jameswtc

    Newbie

  • Members
  • Pip
  • 3 posts
  • LocationSwitzerland

Posted 09 September 2014 - 03:58 PM

I had the same problem, dug into the codes and 100% affirmative avatar image is the culprit. It took up 10 second for the avatar to return a result... (on lucky days it was quick). Commented that part of code to return only the offline image and everything works like a charm now.







Also tagged with one or more of these keywords: lag, latency, latencies, page, secondes, loading, local, server

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users