Jump to content


Photo

Export/Import from Test Site?

installation export import database

  • Please log in to reply
2 replies to this topic

#1 dstaiger

dstaiger

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 28 July 2014 - 08:26 PM

I'm fairly novice with these types of configurations, so any advice would be appreciated.

 

I originally setup Zurmo on a test server to try it out. I have now installed it on our work site. I cannot find a simple way to export data from one instance to the other. I did a backup of the database, but have progressed through a series of errors with that route.

 

Should I continue to attempt loading a backup database from my test server or is there any easier solution?

 

Thanks.



#2 windsor

windsor

    Advanced Member

  • Moderators
  • 272 posts
  • LocationTampa, Florida USA

Posted 31 July 2014 - 05:24 PM

can you give more detail on the errors and your environment?

what version(s) of Zurmo? were both Zurmi the same version?



#3 dstaiger

dstaiger

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 04 August 2014 - 05:48 PM

Thanks Windsor. I figured it out. I had 2.7.3 importing to 2.7.4. I aligned the versions, but am not sure that was my issue. At this point, the error was a syntax issue with '$$$$' in the database. In the end, I finally got it to work when I removed the below text from the database file. 

 
DELIMITER $$
--
-- Procedures
--
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
--
-- Functions
--
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$
 
$$






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users