Jump to content


Photo

login not working because globalmetadata - ZurmoModule after upgrade 2.8

users login bug 2.8 globalmetada ZurmoModule

  • Please log in to reply
5 replies to this topic

#1 hugoxalapa

hugoxalapa

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 08 August 2014 - 08:21 PM

Ok, here is the issue, after upgrade to 2.8 the users can't login anymore, the login screen just hangs with the spinning in the login button, after 20 hours looking for the cause i found that is something in the ZurmoModule row inside the globalmetadata table, i knew because i replace the contents in there with the one with a good install and its login again, however i have a couple questions:

 

1.-Is safe to just replace the code inside ZurmoModule

2.-Is there a way to found out what is causing the issue.

 

Here is the code inside ZurmoModule:

 

 

a:35:{s:18:"configureMenuItems";a:8:{i:0;a:5:{s:8:"category";i:1;s:10:"titleLabel";s:52:"eval:Zurmo::t('ZurmoModule', 'Global Configuration')";s:16:"descriptionLabel";s:59:"eval:Zurmo::t('ZurmoModule', 'Manage Global Configuration')";s:5:"route";s:32:"/zurmo/default/configurationEdit";s:5:"right";s:27:"Access Global Configuration";}i:1;a:5:{s:8:"category";i:1;s:10:"titleLabel";s:54:"eval:Zurmo::t('ZurmoModule', 'Currency Configuration')";s:16:"descriptionLabel";s:61:"eval:Zurmo::t('ZurmoModule', 'Manage Currency Configuration')";s:5:"route";s:33:"/zurmo/currency/configurationList";s:5:"right";s:29:"Access Currency Configuration";}i:2;a:5:{s:8:"category";i:1;s:10:"titleLabel";s:34:"eval:Zurmo::t('Core', 'Languages')";s:16:"descriptionLabel";s:55:"eval:Zurmo::t('ZurmoModule', 'Manage Active Languages')";s:5:"route";s:33:"/zurmo/language/configurationList";s:5:"right";s:27:"Access Global Configuration";}i:3;a:5:{s:8:"category";i:1;s:10:"titleLabel";s:47:"eval:Zurmo::t('ZurmoModule', 'Developer Tools')";s:16:"descriptionLabel";s:54:"eval:Zurmo::t('ZurmoModule', 'Access Developer Tools')";s:5:"route";s:19:"/zurmo/development/";s:5:"right";s:27:"Access Global Configuration";}i:4;a:5:{s:8:"category";i:1;s:10:"titleLabel";s:60:"eval:Zurmo::t('ZurmoModule', 'Authentication Configuration')";s:16:"descriptionLabel";s:67:"eval:Zurmo::t('ZurmoModule', 'Manage Authentication Configuration')";s:5:"route";s:39:"/zurmo/authentication/configurationEdit";s:5:"right";s:27:"Access Global Configuration";}i:5;a:5:{s:8:"category";i:1;s:10:"titleLabel";s:39:"eval:Zurmo::t('ZurmoModule', 'Plugins')";s:16:"descriptionLabel";s:63:"eval:Zurmo::t('ZurmoModule', 'Manage Plugins and Integrations')";s:5:"route";s:32:"/zurmo/plugins/configurationEdit";s:5:"right";s:27:"Access Global Configuration";}i:6;a:5:{s:8:"category";i:1;s:10:"titleLabel";s:60:"eval:Zurmo::t('ZurmoModule', 'User Interface Configuration')";s:16:"descriptionLabel";s:67:"eval:Zurmo::t('ZurmoModule', 'Manage User Interface Configuration')";s:5:"route";s:45:"/zurmo/default/userInterfaceConfigurationEdit";s:5:"right";s:27:"Access Global Configuration";}i:7;a:5:{s:8:"category";i:1;s:10:"titleLabel";s:52:"eval:Zurmo::t('ZurmoModule', 'System Configuration')";s:16:"descriptionLabel";s:59:"eval:Zurmo::t('ZurmoModule', 'Manage System Configuration')";s:5:"route";s:38:"/zurmo/default/systemConfigurationEdit";s:5:"right";s:27:"Access Global Configuration";}}s:15:"headerMenuItems";a:3:{i:0;a:5:{s:5:"label";s:46:"eval:Zurmo::t('ZurmoModule', 'Administration')";s:3:"url";a:1:{i:0;s:14:"/configuration";}s:5:"right";s:25:"Access Administration Tab";s:5:"order";i:1;s:6:"mobile";b:0;}i:1;a:4:{s:5:"label";s:45:"eval:Zurmo::t('ZurmoModule', 'Need Support?')";s:3:"url";s:36:"http://www.zurmo.com/needSupport.php";s:5:"order";i:9;s:6:"mobile";b:1;}i:2;a:4:{s:5:"label";s:43:"eval:Zurmo::t(ZurmoModule' 'About Zurmo')";s:3:"url";a:1:{i:0;s:20:"/zurmo/default/about";}s:5:"order";i:10;s:6:"mobile";b:1;}}s:21:"configureSubMenuItems";a:1:{i:0;a:5:{s:8:"category";i:2;s:10:"titleLabel";s:50:"eval:Zurmo::t('ZurmoModule', 'LDAP Configuration')";s:16:"descriptionLabel";s:58:"eval:Zurmo::t('ZurmoModule', 'Manage LDAP Authentication')";s:5:"route";s:33:"/zurmo/ldap/configurationEditLdap";s:5:"right";s:27:"Access Global Configuration";}}s:31:"adminTabMenuItemsModuleOrdering";a:9:{i:0;s:4:"home";i:1;s:13:"configuration";i:2;s:8:"designer";i:3;s:6:"import";i:4;s:6:"groups";i:5;s:5:"users";i:6;s:5:"roles";i:7;s:9:"workflows";i:8;s:15:"contactWebForms";}s:26:"tabMenuItemsModuleOrdering";a:10:{i:0;s:4:"home";i:1;s:13:"mashableInbox";i:2;s:8:"accounts";i:3;s:5:"leads";i:4;s:8:"contacts";i:5;s:13:"opportunities";i:6;s:9:"marketing";i:7;s:8:"projects";i:8;s:8:"products";i:9;s:7:"reports";}s:18:"defaultFromAddress";s:28:"notification@zurmoalerts.com";s:20:"defaultTestToAddress";s:28:"testJobEmail@zurmoalerts.com";s:29:"readSubscriptionUpdateDetails";a:2:{s:33:"lastReadPermissionUpdateTimestamp";i:1407527403;s:6:"status";i:2;}s:22:"lastZurmoStableVersion";s:9:"2.0.12 ()";s:32:"lastAttemptedInfoUpdateTimeStamp";i:1407169120;s:15:"applicationName";s:19:"Suzuki Veracruz CRM";s:8:"timeZone";s:19:"America/Mexico_City";s:12:"listPageSize";i:10;s:15:"subListPageSize";i:5;s:17:"modalListPageSize";i:5;s:21:"dashboardListPageSize";i:5;s:37:"gamificationModalNotificationsEnabled";b:1;s:22:"realtimeUpdatesEnabled";b:0;s:19:"reCaptchaPrivateKey";s:0:"";s:18:"reCaptchaPublicKey";s:0:"";s:14:"ldapServerType";s:8:"OpenLDAP";s:8:"ldapHost";s:15:"162.209.127.113";s:8:"ldapPort";s:3:"389";s:24:"ldapBindRegisteredDomain";s:5:"admin";s:16:"ldapBindPassword";s:9:"crmauto#1";s:14:"ldapBaseDomain";s:18:"dc=crm-auto,dc=com";s:11:"ldapEnabled";s:1:"1";s:22:"customThemeColorsArray";a:3:{i:0;s:7:"#ed291b";i:1;s:7:"#2478ee";i:2;s:7:"#c0ee5d";}s:16:"globalThemeColor";s:5:"brown";s:18:"forceAllUsersTheme";b:1;s:9:"logoWidth";i:100;s:10:"logoHeight";i:32;s:15:"logoFileModelId";i:1;s:20:"logoThumbFileModelId";i:2;s:11:"globalState";s:88:"a:1:{s:34:"Yii.CSecurityManager.validationkey";s:32:"6c1ea39a50e752af113d3d9325b4f166";}";}



#2 BradPhillips

BradPhillips

    Advanced Member

  • Members
  • PipPipPip
  • 100 posts

Posted 18 September 2014 - 08:46 PM

I'm having this same issue, no user, even the super user, can login to Zurmo.  I can't seem to find anything about this on the bitbucket bug reports and I'm not sure what file you are talking about changing.

 

Are you changing something in the file zurmo/app/protected/modules/zurmo/ZurmoModule.php? I can't find anything in that file that resembles what you posted or anything about the globalemetadata table.

 

I need to get this fixed quickly. Any help or direction I can get would be much appreciated!



#3 speixoto

speixoto

    Advanced Member

  • Members
  • PipPipPip
  • 386 posts

Posted 18 September 2014 - 09:52 PM

Brad, hugo was talking about the globalmetadata table in the DB. I would always make a DB backup before start messing with its data.



#4 BradPhillips

BradPhillips

    Advanced Member

  • Members
  • PipPipPip
  • 100 posts

Posted 18 September 2014 - 10:09 PM

Thanks Speixoto.  DB stuff is over my head. I will have to look for help with that.

 

Is this a common problem with 2.8.2?



#5 speixoto

speixoto

    Advanced Member

  • Members
  • PipPipPip
  • 386 posts

Posted 18 September 2014 - 10:15 PM

I dont know if this a common issue, i did not encontered a live instance that face similar issue for now.



#6 windsor

windsor

    Advanced Member

  • Moderators
  • 272 posts
  • LocationTampa, Florida USA

Posted 21 September 2014 - 05:08 PM

Hi, not sure  that is the root problem. I fixed similar problem for some others here on the forum.  If anybody is still having trouble with the 2.8 upgrade and being locked out and doesn't want to or cant restore and tired of messing with it, just, PM me for options.







Also tagged with one or more of these keywords: users, login, bug, 2.8, globalmetada, ZurmoModule

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users