Jump to content


Photo

Activating memcache on a non-memcache installed Zurmo


  • Please log in to reply
4 replies to this topic

#1 ururk

ururk

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 22 October 2014 - 04:26 AM

I'm trying to install Zurmo on OS X Server...

 

1) I installed Zurmo on MAMP (a developer LAMP stack for OS X). This install was lacking APC and memcache, but was on a fairly new version of php (5.5.+). It worked, ran, and I configured Zurmo as necessary.

 

2) I set up a Mac OS X Server on Mavericks (10.9). I copied the DB and files from my development stack, Zurmo ran fine, but was slow. I installed APC, memcache, and a few other required extensions. After activating memcache everything seemed fine, however all the users (except the super user) kept getting permission errors when trying to do things. 

 

I went ahead and installed a clean version of Zurmo - and all worked fine with users.

 

I tried deleting then re-adding the custom groups I set up, I even tried adding new users. Nothing seems to help. Stacktrace ends with:

 

/Library/Server/Web/Data/Sites/domain/zurmo/yii/framework/base/CComponent.php(606) : eval()'d code(1)

Stack Trace #0
  /Library/Server/Web/Data/Sites/domain/zurmo/app/protected/modules/zurmo/models/OwnedSecurableItem.php(461): SecurableItem->checkPermissionsHasAnyOf(1, User)
456 AllPermissionsOptimizationUtil::checkPermissionsHasAnyOf($requiredPermissions, $this, $user))
457 {
458 return;
459 }
460 }
461 parent::checkPermissionsHasAnyOf($requiredPermissions, $user);
462 }
463 }
464 }
465 ?>

 



#2 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 22 October 2014 - 02:13 PM

Try to uninstall APC, it cause some errors from time to time.

 

Clean cache, logout and try again: 

http://zurmo.org/wik...ystem-explained

 

Are you sure that version of zurmo is same on both installations?



#3 ururk

ururk

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 12 November 2014 - 12:44 AM

Try to uninstall APC, it cause some errors from time to time.

 

Clean cache, logout and try again: 

http://zurmo.org/wik...ystem-explained

 

Are you sure that version of zurmo is same on both installations?

 

I should have posted a reply. On my local development machine, where I originally installed it, I moved all the folders/files within 'zurmo' to the main web folder.

 

I tried many different things (clearing out memcache, disabling apc, etc...). Once I put my files within a folder named 'zurmo' it worked fine.



#4 jschinnerer

jschinnerer

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 14 November 2014 - 09:36 PM

Had apparently identical issue installing on debian linux and then adding memcache - see this bug post:

http://zurmo.org/for...ecurity-errors/

 

APC is not installed on the server so cannot be causing the security issues.

As described in bug report, clearing cache does not fix.

Does anyone have any other experience in fixing this?

 

In particular, is this a result of adding memcache after install and use of Zurmo without memcache?



#5 mivan

mivan

    Advanced Member

  • Members
  • PipPipPip
  • 38 posts

Posted 10 January 2017 - 02:16 PM

I had the same problem for years. It appears that I solved it today by setting securityOptimized = true in debug.php.

My installation is years old, so I don't remember if I enabled memcache after installation of if I moved the app from to /zurmo folder to the webroot. however after enabling this I don't get permission denied errors anymore for non-super users.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users