Jump to content


Photo

Shared MySQL on Arvixe

arvixe MySQL Minimum System Requirements Shared MySQL Database

  • Please log in to reply
2 replies to this topic

#1 Dan

Dan

    Newbie

  • New Members
  • Pip
  • 7 posts

Posted 13 January 2013 - 03:15 PM

Hello,

 

First off, your application is awesome!!!

I'm using Arvixe to host Zurmo 1.0.0 and the shared server I'm using did not meet the minimum requirements.  At first it had a lower version of PHP which I was able to configure to PHP 5.3.  During the install script I received Fatal database errors that would not let me proceed related to the following:

-Max SP Recursion Depth

-Database Optimizer Search Depth

-Database Thread Stack Service

I modified the php's directly to remove the restrictions and it installed successfully.  I guess my questions are related to implications of not configuring the database settings based on the scripts.  I believe user group inheritence might fail, but what features should I stay away from?

Arvixe mentioned that I need to have a dedicated environment to make these changes and the cost of my hosting would have gone up 6x.  Any help is appreciated.  Here are the files and changes made to the install scripts.

-----------------------------------------------------------------------------------

/home/user/public_html/zurmo/app/protected/modules/install/serviceHelpers/DatabaseOptimizerSearchDepthServiceHelper.php

Changed protected $required = false; (was originally true)

-----------------------------------------------------------------------------------

/home/user/public_html/zurmo/app/protected/modules/install/serviceHelpers/DatabaseMaxSpRecursionDepthServiceHelper.php

Changed protected $minimumRequiredMaxSpRecursionDepth = 0; (was originally 20)

-----------------------------------------------------------------------------------

/home/user/public_html/zurmo/app/protected/modules/install/serviceHelpers/DatabaseThreadStackServiceHelper.php

Changed protected $minimumRequiredThreadStackValue = 262144; (was originally over 64K)

-----------------------------------------------------------------------------------

Thanks again and looking forward to learning Zurmo!,

Dan



#2 Jason

Jason

    Administrator

  • Administrators
  • 864 posts
  • LocationChicago

Posted 13 January 2013 - 04:40 PM

For a basic use case you might be ok with those settings you have.  To be honest, we are working to eliminate those as a requirement. With a very complex role/group setup you could have problems and searching 30 fields at a time would also potentially cause a problem but other than that you should be ok.  It would be great if you could run the unit tests and let us know the results.


Jason Green
Zurmo Team
Need support? Upgrade now


#3 arvand.arvixe

arvand.arvixe

    Newbie

  • New Members
  • Pip
  • 3 posts

Posted 25 June 2013 - 07:44 AM

Hello,

 

I'm sorry for the delay in reply. We are working on a liaison who will be on top of such issues in the future. For anyone else that may be looking at this -

 

While on older servers, customers can choose PHP 5.3 themselves through the control panel, newer servers provision all users as PHP 5.3 (and you can choose 5.2 or 5.4 after setup)

 

You should be able to autoinstall Zurmo through Softaculous however if you wish to install yourself and run into those errors, simply email us and we'll change the settings for you. We've made sure that individuals on staff are aware that they can make such changes for customers.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users