Jump to content


Photo

Error in checkserviceutil class.

mysql check service config issues configuration issues

  • Please log in to reply
11 replies to this topic

#1 Irungovel

Irungovel

    Member

  • New Members
  • PipPip
  • 15 posts
  • LocationChennai

Posted 19 January 2012 - 01:15 PM

And also i met this problem during zurmo installation. I have installed xampp in my windows pc. Server version: 5.5.8 installed in my pc along with xampp.

But i got this error in zurmo installation . MYSQL is not installed, mininum version 5 required.

Question:
how zurmo checkserviceutil decides, mysql is not installed in my pc even it is installed and many databases created in that. ???

I did this step and done the installation myself.

1. removed database from the array in getServicesToCheck() function at class "CheckServiceUtil".
2. by this i hide/ignore the error "MYSQL is not installed" and continue with installation.

note: installation is done.

but, i need to figure out the solution to this type of errors without commenting/removing lines in exisitng zurmo code.

COULD YOU ANYONE HELP ME ?


Thanks,

#2 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 19 January 2012 - 01:36 PM

There are two phases in CheckServiceUtil.php, one on initial installation screen(getServicesToCheck() function), and one after you enter your database, server info(getAdditionalServicesToCheck()). For some reason, installation script was not able to connect and check version of your database. DOes your database running on standard 3306 port or custom?

#3 Irungovel

Irungovel

    Member

  • New Members
  • PipPip
  • 15 posts
  • LocationChennai

Posted 19 January 2012 - 03:01 PM

Hi Ivica, thank you so much for your immediate reply.

yes my database running on standard port 3306 only. what may be the reason of this issue. ?

#4 Jason

Jason

    Administrator

  • Administrators
  • 864 posts
  • LocationChicago

Posted 19 January 2012 - 06:12 PM

Can you make a simple php script and try the following:


$connection = @mysql_connect($databaseHostname, $databaseUsername, $databasePassword);
$result = @mysql_query("SELECT VERSION()");
$row = @mysql_fetch_row($result);

I am curious what is being returned by that using the same user/pass/host that you are using for zurmo.

Jason Green
Zurmo Team
Need support? Upgrade now


#5 Irungovel

Irungovel

    Member

  • New Members
  • PipPip
  • 15 posts
  • LocationChennai

Posted 20 January 2012 - 07:50 AM

Yes, i checked this in both programming and phpmyadmin itself... mysql version is higher than 5 only. 5.5.8.

Executed code to find the mysql version.
<?php
$dbconfig = parse_ini_file("dbconfig.ini");
$dbhost = $dbconfig['dbhost'];
$dbusername = $dbconfig['dbuser'];
$dbpwd = $dbconfig['dbpass'];
$connection = @mysql_connect($dbhost, $dbusername, $dbpwd);
$result = @mysql_query("SELECT VERSION()");
$row = @mysql_fetch_row($result);
echo "Mysql Version ".$row[0];
?>



We have solved this mismatching service check in zurmo. Just commented/removed the dbcheck service and completed the installation. Zurmo application is working good for me. But still i would like to get solution without do comment the existing code and functionalities. Kindly help me to sort out this.

private static function getServicesToCheck()
	    {
		    return array('WebServer',
						 'Php',
						 'PhpTimeZone',
						 'PhpMemoryBytes',
						 'PhpFileUploads',
						 'PhpUploadSize',
						 'PhpPostSize',
						 'FilePermissions',
    'Database',
						 'DatabaseMaxAllowedPacketSize',
						 'APC',
						 'Soap',
						 'Tidy',
						 'Curl',
						 'Yii',
						 'RedBean',
						 'MbString',
						 'Memcache',
		    );

File path: \zurmo\app\protected\modules\install\

#6 Irungovel

Irungovel

    Member

  • New Members
  • PipPip
  • 15 posts
  • LocationChennai

Posted 20 January 2012 - 11:00 AM

now i downloaded and installed the new version of zurmo "zurmo-stable-0.5.7.5e2af02aace9.tar.gz" which version is released on . mysql server not found error is not populating. i set thread_stack to 550K and done the installation.

now installation process is going with 0.5.7 .

#7 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 20 January 2012 - 12:21 PM

Glad to hear that you finally installed it without problems, because checkings have purpose to force you to fix problems before completing installation, and avoid bugs, so it is not recommended to remove them.

#8 Irungovel

Irungovel

    Member

  • New Members
  • PipPip
  • 15 posts
  • LocationChennai

Posted 20 January 2012 - 12:41 PM

Hi Ivica,

Thank you so much for you kind support so far. But still i would like to perform unit tests and run phpunit with zurmo applications. again i have started to work with phpunit configuration.

For that, new database is created for unit test and db credentials configured in "perInstance.php" and started now.

I will update you soon.

Thanks,

#9 Jason

Jason

    Administrator

  • Administrators
  • 864 posts
  • LocationChicago

Posted 20 January 2012 - 02:14 PM

Great.

Jason Green
Zurmo Team
Need support? Upgrade now


#10 Irungovel

Irungovel

    Member

  • New Members
  • PipPip
  • 15 posts
  • LocationChennai

Posted 20 January 2012 - 03:00 PM

Thank you so much Ivica and Json. Now i have got work with unitest classes with phpunit also.

If we give few more details in our zurmo installation wiki page, then that would great helpful to new zurmo developers/users.

Is there any other packages to do the unit tests with zurmo application apart from phpunit. ?


Thanks,

#11 Irungovel

Irungovel

    Member

  • New Members
  • PipPip
  • 15 posts
  • LocationChennai

Posted 23 January 2012 - 06:56 AM

Hi Json & Ivica,

I just wrote a test class for utility class "RequiredAttributesValidViewUtil". May i send to you ?

Thanks,

#12 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 23 January 2012 - 11:52 AM

Yes, you can send it to Jason and me. Please check PM for our email addresses.

Thanks





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users