Jump to content


Photo

install new language

language

  • Please log in to reply
5 replies to this topic

#1 MrCRM

MrCRM

    Member

  • New Members
  • PipPip
  • 15 posts

Posted 04 February 2013 - 07:24 PM

Hey i am trying to add a customer language and i have made all files and added them i the message folder of all modules and the app itself, and in config.php i have added it: 'supportedLanguages' => array( 'en' => 'English', 'ru' = > 'Russian', 'es' => 'Spanish', 'it' => 'Italian', 'fr' => 'French', 'de' => 'German', When i try to reload my server i does not work? i just get errors? i made a file PerInstanceConfig.php added in config tried to open just saw the following: $instanceConfig['params']['supportedLanguages']['ru'] = 'Russian' help please

#2 Ivica

Ivica

    Advanced Member

  • Moderators
  • 486 posts

Posted 05 February 2013 - 02:32 AM

Can you please post errors that you get.



#3 MrCRM

MrCRM

    Member

  • New Members
  • PipPip
  • 15 posts

Posted 05 February 2013 - 07:40 PM

just 500 internal server error all the time, have to go to database and change language of user, and it only counts for the user that got the new language, site works fine for the other ones.... 



#4 Ivica

Ivica

    Advanced Member

  • Moderators
  • 486 posts

Posted 06 February 2013 - 02:46 AM

Please post content from app/protected/runtime/application.log, related to this request, I need more details on this issue.



#5 madebybel

madebybel

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 06 March 2013 - 09:25 AM

Same error on adding dutch language.... any help?



#6 madebybel

madebybel

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 07 March 2013 - 12:06 AM

2013/03/06 08:11:18 [error] [php] chmod(): Operation not permitted (/Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/app/protected/core/components/ZurmoExtMinScript.php:61)
Stack trace:
#0 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/yii/framework/base/CModule.php(103): WebApplication->getComponent()
#1 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/app/protected/core/views/PageView.php(251): WebApplication->__get()
#2 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/app/protected/core/views/PageView.php(63): LoginPageView->renderXHtmlHead()
#3 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/app/protected/modules/zurmo/controllers/DefaultController.php(69): LoginPageView->render()
#4 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/yii/framework/web/actions/CInlineAction.php(49): ZurmoDefaultController->actionLogin()
#5 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/yii/framework/web/CController.php(308): CInlineAction->runWithParams()
#6 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/yii/framework/web/filters/CFilterChain.php(133): ZurmoDefaultController->runAction()
#7 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/yii/framework/web/CController.php(291): CFilterChain->run()
#8 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/yii/framework/web/CController.php(265): ZurmoDefaultController->runActionWithFilters()
#9 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/yii/framework/web/CWebApplication.php(282): ZurmoDefaultController->run()
#10 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/yii/framework/web/CWebApplication.php(141): WebApplication->runController()
#11 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/yii/framework/base/CApplication.php(169): WebApplication->processRequest()
#12 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/app/protected/core/components/WebApplication.php(48): WebApplication->run()
#13 /Applications/XAMPP/xamppfiles/htdocs/develop/zurmo/app/index.php(56): WebApplication->run()
REQUEST_URI=/develop/zurmo/app/index.php/zurmo/default/login
 







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users