Jump to content


Photo

Can't modify the maximum field length

field length max

  • Please log in to reply
1 reply to this topic

#1 VicKC

VicKC

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 27 May 2015 - 10:08 AM

Hi Zurmo team,

 

 

Thank you for making this amazing CRM solution.

 

 

I am trying to import existing data into Zurmo.

 

However, there are some data cannot be imported due to maximum length limit.

 

eg. officePhone

(import analysis gave warning of limit 24 char)

 

I tried the following instruction, it worked for "street1" field but not officePhone field.

http://zurmo.org/for...-fields-lenght/

 

I modified the column in mysql database and Account.php, Person.php files.

 

It did not work.

 

Please help.

 

Victor W 



#2 Ivica

Ivica

    Advanced Member

  • Moderators
  • 565 posts

Posted 02 June 2015 - 08:34 AM

you need to modify rules only in Account/Person.php file, after that open page with clearCache=1 in url, and finally update schema(./zurmoc updateSchema super)

Don't modify any fields directly in database!!!

 

Maybe you will need to delete global metadata for Account/Person, but in that case you might lost some fields that you added via designer for these models.







Also tagged with one or more of these keywords: field, length, max

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users