Jump to content


Photo

Accounts import file per owner

onwers accounts import csv rules

  • Please log in to reply
5 replies to this topic

#1 Risx

Risx

    Member

  • Members
  • PipPip
  • 21 posts

Posted 03 July 2015 - 08:12 AM

hi,

 

I want to upload a csv with aprox 20000 accounts, each account with his owner.

So I will have 10 owners with 2000 accounts each.

I don't want the owners to see other accounts than theirs.

When I want to upload the file I can only select the group that can read and write the content, but nothing else that can help me splitting these accounts per owners.

 

Thx



#2 oldrose

oldrose

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationAustralia

Posted 05 July 2015 - 11:14 PM

Why don't you add the owner column to your import and import with the permission owner only?



#3 Risx

Risx

    Member

  • Members
  • PipPip
  • 21 posts

Posted 06 July 2015 - 12:19 PM

Yes that is one solution, but then the managers won't be able to see the accounts with their owners.

for example:

I want each sales agent to see his accounts only, and the managers to see the accounts for all agents.

If i import a file with the owner column, with the permission owner only...each agent will see his/her accounts, but the managers will see nothing. Maybe the super user will be able to see something.

Please correct me if I  am wrong.

 

tnx,



#4 oldrose

oldrose

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationAustralia

Posted 07 July 2015 - 09:30 AM

You need to look at roles.



#5 Risx

Risx

    Member

  • Members
  • PipPip
  • 21 posts

Posted 14 July 2015 - 11:53 AM

Yes the roles should do it, but then another issue shows up after setting up the roles.

If you go to accounts and want click on the bottom arrow to see more accounts a script error appears. Is not triggering an Ajax

 

Error 500: <script>&('#zurmoSentryId').append('The reference id for this error is 5823118cd69467d9355cb082c08658c.');</script>

 

Any clue why this shows up?

Attached Thumbnails

  • error500.PNG


#6 Risx

Risx

    Member

  • Members
  • PipPip
  • 21 posts

Posted 16 July 2015 - 09:03 AM

fixed it in the end by changing these two params. as bellow

 

$securityOptimized = true

$memcacheLevelCaching = false







Also tagged with one or more of these keywords: onwers, accounts, import, csv, rules

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users