Jump to content


Photo

[RESOLVED] no hyperlink in a custom module ListView

custom module link ListView

  • Please log in to reply
2 replies to this topic

#1 windsor

windsor

    Advanced Member

  • Moderators
  • 272 posts
  • LocationTampa, Florida USA

Posted 20 March 2013 - 12:37 AM

Symptom:

 

You create a new custom module. You successfully install the module. You click on the module name in the green menu in the upper left of the screen. You then see a combined search and list view.  BUT ... there is no hyperlink on an attribute in the row. so you can't click the attribute name to open the object. HOWEVER... the edit icon at the end of the row does work.

 

Solution:

 

Check your model, and make sure that you haven't declared the attribute in the elements section of metadata.  I made this mistake and it appeared to override the getIsLink functionality of  TextListViewColumnAdapter.

 

 'elements' => array(
                    'animal'	=> 'Animal',
                    //'name'	=> 'TextArea',  // <- don't do this if you want 'name' to be a hyperlink on the list view.
					
 ),

 

 

Remember to run 'zurmoc UpdateSchema super' after you fix the error.

 

HTH.

 

(by the way if someone can share the best way to add screen shots to a post I will update this with some pics)

 

 

 



#2 raysto

raysto

    Zurmo Team

  • Administrators
  • 1,973 posts

Posted 20 March 2013 - 01:29 AM

AHA! Fabulous! You figured it out! Now our Dev Session this morning has some kind of victory associated with it. If you want to add pics to the Forums post, hit "Edit", then "Use Full Editor". Then you can "Attach files" by browsing your hard drive. If you create a new reply, hit "More Reply Options" instead of just "Post"


Ray Stoeckicht
Zurmo Team
Try Zurmo Pro


#3 windsor

windsor

    Advanced Member

  • Moderators
  • 272 posts
  • LocationTampa, Florida USA

Posted 20 March 2013 - 02:46 AM

example screenshot

Attached Thumbnails

  • zumo_custom_list_1.PNG






Also tagged with one or more of these keywords: custom module, link, ListView

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users