Jump to content


Photo

Opportunity > Products portlet opens product details in misplaced modal box

product portlet modal 3.1.5

  • Please log in to reply
4 replies to this topic

#1 fodora

fodora

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 11 July 2016 - 01:29 PM

Hello!

 

We updated Zurmo to the latest stable version (3.1.5).

In Opportunity view, when you open a related product from the Product portlet, it opens in a modal box.

First, it would be nice to turn off this feature and open the products in a normal product view, not modal. Like in the older versions. I couldn't find it in the settings.

Second, the modal box opens in the bottom of the page on the left (it doesn't get any top and left value from JS). You have to scroll down or move the modal box if you would like to see the content.

 

Is there any way to fix it?

 

Thank you very much for any help!

András

Attached Thumbnails

  • screenshot-2016-07-11 15-26-47.jpg


#2 Ross

Ross

    Advanced Member

  • Administrators
  • 53 posts
  • LocationBuenos Aires

Posted 25 July 2016 - 03:00 PM

Thanks for reporting this issue.  I have confirmed it in the stable demo on our website also.  

 

A bug has en submitted to our engineering team to fix the UI issue causing the modal to appear at the bottom of the screen.  

 

Separately a Feature request has been submitted to allow admins to disable the modal products view as an option in designer since this is not currently configurable inside the app.


Ross Peetoom
Zurmo Team
Ross@zurmo.com

#3 pmontanez

pmontanez

    Member

  • Members
  • PipPip
  • 18 posts

Posted 06 October 2016 - 05:37 PM

Hey Ross,

 

Any Update on this Bug report, it's being a couple months unresolved. Perhaps  Any workaround while we wait for final release...

 

Thanking you in advance!



#4 damianatorrpm

damianatorrpm

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 03 December 2016 - 06:42 PM

modules/products/utils/ProductsUtil.php 

replace line 159 with

                array('my'=>'center top+25','at'=>'center top+25'), $class = "'product-dialog'", 
 


#5 Boban Perić

Boban Perić

    Zurmo Engineer

  • Administrators
  • 23 posts

Posted 20 December 2016 - 07:06 PM

This is fixed in 3.2.0







Also tagged with one or more of these keywords: product portlet, modal, 3.1.5

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users