Jump to content


riwern

Member Since 22 Dec 2013
Offline Last Active Jul 03 2016 10:07 PM
-----

#13452 Reports - Extending the use of Date filters (default value: now)

Posted by riwern on 02 April 2014 - 01:16 PM

I believe there is a missing key option when it comes to handling date fields in the reports module, specifically the filtering. Being forced to hardcode a value for "Before" or "After" might be considered an annoyance, but for the users having to constantly change this each time it's becoming an issue (subjectively speaking of course).

Now the issue lands on my desk and I as an administrator cannot ease their pain since there is no option as far as I have been able to find out to add a default value to "now" or "today" (or whatever is the most appropriate term for its use) for report filtering.

 

These kinds of filtering are especially useful for business selling services/subscriptions where you have an end date and you really want to know if they've been renewed, expired, etc not just for the last 7 days which is the "next best thing" right now. 

 

 

My humble request is to "simply" add the option of "today" to date field filters in reports.




#13427 Exporting Reports to CSV

Posted by riwern on 01 April 2014 - 08:22 AM

I've run into more or less the same problem.
I still haven't found a solution for my problem although I've narrowed it down to what's causing the situation for me: execution time.
 
Check your (apache) logs for errors similar to "PHP Fatal error:  Maximum execution time of 300 seconds exceeded in...". It's due to that the jobManager has a 300 second execution limit regardless of your php settings on the server.
 
If you supply an argument to the jobManager you can manually try a larger value like:

php ./zurmoc jobManager <super user> Export 3600

Which in this case changes the execution time limit to 3600 seconds instead of the default 300.
 
If it works for you, you may also try adding the larger value to your cron job as well. For some reason the jobs keep piling up after a while for me but you may have better luck finding values that work. This might be a separate issue so I'll be creating my own thread for that.
 
--igu