Jump to content


RayGauthier

Member Since 19 Dec 2014
Offline Last Active Jan 11 2015 06:58 PM
-----

#15611 Merge fileds in workflow mail

Posted by RayGauthier on 11 January 2015 - 07:03 PM

I've done a bit more testing and, without testing all of them, the only fields that don't seem to resolve or be interpreted in a Workflow Template are [[UNSUBSCRIBE^URL]] and [[MANAGE^SUBSCRIPTIONS^URL]] .

Pretty important to be able to have an unsubscribe link in my workflows.

Tried replicating in the test site but it doesn't seem to send email so I can't replicate there.

 

Essentially, on my system, (using 2.8.5) I have a marketing signature.  When I insert either the unsubscribeUrl or the manageSubscriptions url in an autoresponder, the email the recipient received has the link and value pair hash to unsubscbe.  When I insert them in to a workflow template and the worfflow sends the email to the lead/contact, the recipient sees the raw  [[UNSUBSCRIBE^URL]] or  [[MANAGE^SUBSCRIPTIONS^URL]]  as plain text.




#15609 Last Name mandatory in Lead

Posted by RayGauthier on 11 January 2015 - 04:15 PM

FYI - I was able to resolve (kinda) by making the last-name hidden.




#15419 Has anyone got cron jobs working on BlueHost.

Posted by RayGauthier on 21 December 2014 - 01:50 PM

Has anyone been successful at getting the job manager cron jobs to work in BlueHost shared hosting?

First off -- many thanks to everyone who has posted solutions - I've tried so many of them I can't even begin to find them all and give proper attribution. 

 

A bit of background to help understand what I have tried:

 

PHP version is 5.4.34

zurmo is installed in subdomain/subfolder:  tribeshepherd/zurmo

My home/root directory and user is" home1/gentlewe/public_html/

My zurmo super admin id is: "tribesu" - not the default "super"

 

According to phpinfo(), loaded config file is: /usr/php/54/etc/php.ini

 

==================================================

 

Based on the many solutions/recommendations posted, here is what I have tried and the results.

 

1)

/usr/php/54/usr/bin/php -c /usr/php/54/etc/php.ini /home1/gentlewe/public_html/tribeshepherd/zurmo/app/protected/commands/zurmoc jobManager tribesu CampaignQueueMessagesInOutbox

 

This "should" force the use of PHP 5.4 and use the default php.ini.

 

#1 produces this error

PHP Parse error:  syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home1/gentlewe/public_html/tribeshepherd/zurmo/app/protected/core/components/WebApplication.php on line 175

 

2)
/usr/php/54/usr/bin/php -c /home1/gentlewe/public_html/php.ini /home1/gentlewe/public_html/tribeshepherd/zurmo/app/protected/commands/zurmoc jobManager tribesu CampaignQueueMessagesInOutbox
 

this should use php 5.4 but use the php.ini that is in root instead of the one that is in bin.

 

#2 produces the same error as # 1

PHP Parse error:  syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home1/gentlewe/public_html/tribe

shepherd/zurmo/app/protected/core/components/WebApplication.php on line 175

 

3) php /home1/gentlewe/public_html/tribeshepherd/zurmo/app/protected/commands/zurmoc jobManager tribesu CampaignQueueMessagesInOutbox

 

this does now force the use of php 5.4 or default php.ini

 

#3 also produces the same T_PAAMAYIM_NEKUDOTAYIM error.   (which, again thanks to all the previous support, technically means the cron is likely trying to use a version of PHP prior to 5.3 which produces an error on double colons and instead wants "->")

 

4) cd /home1/gentlewe/public_html/tribeshepherd/zurmo/app/protected/commands/  && php ./zurmoc jobManager tribesu CampaignQueueMessagesInOutbox

 

5) cd /home1/gentlewe/public_html/tribeshepherd/zurmo/app/protected/commands;
 /usr/local/bin/php /home1/gentlewe/public_html/tribeshepherd/zurmo/app/protected/commands/zurmoc jobManager tribesu CampaignQueueMessagesInOutbox

 

6) cd /home1/gentlewe/public_html/tribeshepherd/zurmo/app/protected/commands;
/usr/php/54/usr/bin/php /home1/gentlewe/public_html/tribeshepherd/zurmo/app/protected/commands/zurmoc jobManager tribesu CampaignQueueMessagesInOutbox

 

#4, 5 & 6 all produce the following error

PHP Notice:  Undefined index: SCRIPT_FILENAME in /home1/gentlewe/public_html/tribeshepherd/zurmo/yii/framework/base/CApplication.php on line 142

 

If anyone has the cron jobs working on BlueHost shared hosting, I'd very much appreciate understanding exactly what your cron code looks like - or if you were able to successfully explain the issue to Bluehost (how you did that) and got them to help.

 

Thanks,

Ray

all