Jump to content


davewyers

Member Since 26 Jun 2013
Offline Last Active Feb 12 2014 09:24 PM
-----

Posts I've Made

In Topic: turnkey linux install just isn't working

26 June 2013 - 07:30 AM

Hi All,  
 
I have struck the same problem so you may find this of some assistance.
 
In short once you have run the first boot of the Turnkey Zurmo image what do you do to correct or alter the hostname that Zurmo looks for?
 
As the root user, shell to the server and type;

turnkey-init

You will need to reenter both the set up passwords and hostname.
 
 
Background
 
As at writing the current image version on the the Turnkey site is 12.1 (Thu, 2013/06/06 - 16:59) and this includes the Zurmo Upstream source component versions:

  • zurmo-stable 1.1.31.658d8cfa5c16 (i386)
  • zurmo-stable 1.5.14.67bf4e0edaaa (amd64)

 
The Turnkey image will run a process on first boot of the system to configure the system passwords and the Zurmo hostname called turnkey-init and this in turn runs the following Python script ;

  • /usr/lib/inithooks/bin/zurmo.py

part of the script is show below.

...
if not domain:                                                                                                           
        if 'd' not in locals():                                                                                              
            d = Dialog('TurnKey Linux - First boot configuration')                                                           
                                                                                                                             
        domain = d.get_input(                                                                                                
            "Zurmo Domain",                                                                                                  
            "Enter the domain to serve Zurmo.",                                                                              
            DEFAULT_DOMAIN)                                                                                                  
                                                                                                                             
    if domain == "DEFAULT":                                                                                                  
        domain = DEFAULT_DOMAIN

    hash = hashlib.md5(password).hexdigest()

    m = MySQL()
    m.execute('UPDATE zurmo._user SET hash=\"%s\" WHERE username=\"admin\";' % hash)

    conf = "/var/www/zurmo/app/protected/config/perInstance.php"
    system("sed -i \"s|hostInfo.*|hostInfo'] = 'http://%s';|\" %s" % (domain, conf))
...

Looking at the config file /var/www/zurmo/app/protected/config/perInstance.php we find that the host detail is located on the following line.

 

  • $instanceConfig['components']['request']['hostInfo'] = 'http://HOSTNAME';    

You could just edit the file directly to replace HOSTNAME with either the IP address or hostname of your system.  You can also run the turnkey-init command.
 
 
The current release version is zurmo-stable-2.0.6.6850b74d6b27 and this looks to have a slightly different file layout as I noticed that the filename has changed to perInstanceDIST.php and the host line is now commented out.
 
  //$instanceConfig['components']['request']['hostInfo'] = '';
  //$instanceConfig['components']['request']['scriptUrl'] = ''; 
 
Ray, can you advise if that setting has moved or if you have depreciated its use now?
 
Regards
 
Dave